Solved BIOS Update failed. Battery Below Ten Precent. Dell XPS 15z

September 3, 2016 at 06:46:37
Specs: Windows 7 Professional, I7 16G Ram
I am trying to update my BIOS Because my battery is at zero precent and not charging. I have tried running the bios update .exe through administrative cmd, with and without /Forceit, /Forcetype, and /jabil
Battery is healthy, AC adapter is correct wattage but unrecognized by my current bios, wich is what is prompting me to update. Please. Help.

See More: BIOS Update failed. Battery Below Ten Precent. Dell XPS 15z

Report •

#1
September 3, 2016 at 07:25:50
Flashing the BIOS with only 10% battery and no AC current is an invitation for making a brick. I recommend you do not attempt flashing the BIOS that way.

Does the laptop currently boot to Windows or at least POST?

Is the charger branded to the laptop?

Did the charger ever work with this laptop?

Has this battery previously worked in that laptop?

How old is the battery?

message edited by OtheHill


Report •

#2
September 3, 2016 at 07:29:38
✔ Best Answer
The Dell site is the ONLY place you should be getting the BIOS from. The latest version for your laptop is A12, dated 26 Oct 2012. All you need to do is download it & then double click on it. The file name is L511ZA12.exe. The laptop MUST be powered up by the AC adapter. Do NOT attempt a BIOS flash under battery power. In fact, since the battery seems to be a problem, I suggest you remove it altogether during the flash.

http://www.dell.com/support/home/us...


Report •
Related Solutions


Ask Question