Belkin 7 Port USB Hub

Asus / G72
November 12, 2009 at 22:41:34
Specs: Windows 7 64 bit, core duo / 6 GB ram
I am trying to install a Belkin 7 Port USB Desk Hub. I plug it into one of the USB port and the sound you here when plugging in devices come on. Then get an error saying driver did not install.

When I view device manager I see this "BLUETOOTH USB + EDR ADAPTER CLASS1 V2.1 UHE" with an exclamation mark to it. I am assume this has something to do with the USB Hub.

I can't find anything on this. I can't find any updated driver from Belkin's website.

Anyone have any suggestions?

This Hub and Laptop was just purchased yesterday.


Brian


See More: Belkin 7 Port USB Hub

Report •

#1
November 13, 2009 at 01:30:23
Have you tried updating the driver through the device manager? If so or if you still get nothing there I would return it.
In device manager right click on the adapter and click propeties. What does it say under the general tab?

Likely

I want to go like my grandfather did. Peacefully in his sleep. Not screaming at the top of my lungs like the passengers in his car.

(\__/)
(='.'=)
(")_(")


Report •

#2
November 13, 2009 at 01:33:26
I know silly question but is the power plugged in?

Likely

I want to go like my grandfather did. Peacefully in his sleep. Not screaming at the top of my lungs like the passengers in his car.

(\__/)
(='.'=)
(")_(")


Report •

#3
November 13, 2009 at 07:05:14
Yes, I have tried updating the driver from within device manager. It says “The best driver software for your device is already installed.”

Under general tab it shows:
BLUETOOTH USB + EDR ADAPTER CLASS1 V2.1
Device type: Bluetooth Radios
Manufacture: Broadcom
Location: Port_#0002 Hub_#0008
Device status: This device cannot start (Code 10)


That is where I get confused. This is a Belkin 7 Port Hub and it’s not wireless so I don’t understand the Bluetooth part.

When I unplug the Hub the Bluetooth USB in device manager disappears.

This HUB works great for my sisters hubby computer which also has Windows 7 and it works in my other laptop with Vista. And it also worked for about the first 5 minutes or so in this computer. Windows did an automatic update and it hasn’t worked since.

Yes it is plugged in.

Brian


Report •

Related Solutions

#4
November 14, 2009 at 06:11:52
I took the Belkin back to Best Buy and ended up going to Staples and buying a Staples brand 7 port USB hub. Works great.

Brian


Report •

#5
November 29, 2009 at 09:19:46
This just happened to me after installing the windows update:

BLUETOOTH USB + EDR ADAPTER CLASS1 V2.1

Easy to fix, under the properties tab of your belkin usb hub go to" Properties" then "Change settings" then click the "Driver" tab and select "Roll Back Driver". Your hub will re-connect and devices work properly again


Report •

#6
December 4, 2009 at 12:38:23
Thanks, pokajunkie! "Roll Back Driver" was greyed out for me,
but I clicked "Uninstall", then "Remove drivers" and the device
was detected as a generic USB hub.

Report •

#7
January 21, 2010 at 04:20:04
Random thank you - I had this exact same issue and response number 6 marked the successful end of what was 2 hours of frustration

Report •

Ask Question