Solved An external USB boot drive disaster

Gigabyte / Ga-78lmt-s2p
December 7, 2012 at 15:44:31
Specs: Windows 7 - 64Bit, 3.6 GHz / 8173 MB
For many years I ran two Win 7 installations on my computer, one was on a HDD installed in the tower and the other was in a HDD Enclosure also mounted in the tower. I did this so that I could experiment with new software on a system which I did not mind damaging and if I did I simply installed a fresh image of the "good" system.

I have since updated to Win7/64bit (8gig RAM) and a new tower. I no longer have installed enclosures but I do have an external USB enclosure, I also have a spare 160gig IDE drive and I determined to do the same again and I have run into all sorts of problems. The first mistake I made was to install, using Acronis, an image of the old Win7/32bit (3gig RAM) to the disk and it failed monumentally (different drivers, different RAM... you name it).

This is my BIOS information:

BIOS Properties:
BIOS Type Award Modular
BIOS Version F2
Award BIOS Type Award Modular BIOS v6.00PG
Award BIOS Message GA-78LMT-S2P F2
System BIOS Date 03/20/12
Video BIOS Date 03/06/12

BIOS Manufacturer:
Company Name Phoenix Technologies Ltd.
Product Information

The second path I took was to install an image, using Acronis, of the existing Win7/64bit bit system to the IDE drive. In the "Advanced BIOS Features" of the BIOS I changed the boot order so that the USB drive was the first one. The boot process went all the way to the Win7 splash screen and at this point there was a sudden flash of a blue screen and the boot process started again.

My local PC tech advised that I should go into "Integrated Peripherals" and change "OnChip SATA Type" from [Native IDE] to [AHCI]. I am not sure why but in any event the boot process failed in exactly the same way as I have described above, and Microsoft in their infinite wisdom will not allow a fresh install to a USB drive so it appears I am snookered.

Any advice on what I have done inocorrectly or that I have not done will be much appreciated.

See More: An external USB boot drive disaster

Report •

December 7, 2012 at 18:19:40
Windows 7 uses a BCD store that uses a custom created Drive ID for each drive. When you cloned the drive from the old physical disk to the new physical disk, it changed the drive ID, so the BCD store is failing to load into Windows as it cannot find the proper drive.

I will bet that if you press F8 at start-up and select the "Disable Automatic Restart on System Failure" option, that the message displayed on the BSOD is either a STOP 0x7B "Inaccessible Boot Device" or STOP 0xEB "Unmountable Boot Volume".

Fortunately, this is an easy fix about 70% of the time. Simply use a Windows 7 install CD to boot the computer into the start-up recovery console and let it try to fix the BCD store. If that does not work, select the Command Prompt option from the list of repair choices once the automated fix fails and run the following commands:

bootrec /fixboot
bootrec /fixmbr
bootrec /ScanOS

The first 2 commands write a new bootsector and mbr to the boot drive. The second will scan the drives for any Operating systems and show which ones (if any) are found that are not in the existing BCD store.

If neither of these options work, then we may have to check into more advanced tools to edit the BCD store directly.

Let me know your results or if you have any questions.

IT Desktop & Network Consultant - MOS Master Certified, MCP, MCSA, MCITP - Windows 7, CCNA Certificate Pending, A+, Network +


Report •

December 7, 2012 at 21:54:40
Well SongCloud you were spot on with your prediction of the error. I carried out your instructions and would you believe it took 25 minutes to check the system and that check failed (you predicted that too). I used the Command Prompt and ran the three commands as you instructed.

On completion I rebooted and was presented with this statement on the Post Screen "Warning No Device Detected". The boot process carried on right up until the Windows splash screen and once again I got the flash of a blue screen. I disabled the Automatic Restart function again and once again the 0x7B error was shown.


Report •

December 7, 2012 at 23:42:05
✔ Best Answer
I'm fairly certain that you cannot actually run Windows from a USB drive directly - it's something that was built-into the design by Microsoft for Vista and Win7. The only way I have seen it done is by using a USB to SATA adapter which does work because Win7 will boot from any SATA drive, internal or external.

"I've always been mad, I know I've been mad, like the most of us..." Pink Floyd

Report •

Related Solutions

December 8, 2012 at 14:18:39
Thank you johnr that is certainly something worth thinking about and the more I do the more I think you are correct. I may be traveling a fanciful path here. The thing is that I used to run two systems, one was resident in the tower and the other was contained in an enclosure which slid into a housing mounted within the tower. My new tower does not have the enclosure mounted and I sold the old tower complete. I thought that an external enclosure would work but it seems it may not.

Late edit:

It seems that you may be right... Windows will not boot from an external drive and there are plenty of posts in this respect. I spent considerable time this morning paging backwards and forwards through Google without success. There are complicated methods for installing the system to an external drive but after reading through them the effort is considerable. I may have to go down another path methinks!

Extra late Edit:

This YouTube tutorial seems to be the way to go but I'm not sure I have the "know how" to go with it. I'll make sure I have all the files mentioned in the tutorial and when I can garner enough courage I'll tackle it.

Report •

Ask Question