Acer Aspire Laptop Cannot Enter Bios? Please help.

Acer Aspire one aod250-1116 netbook
December 25, 2011 at 15:59:48
Specs: Windows XP Professional, 1.8Ghz/3Gb
Laptop: Acer Aspire 5332
Operating System: Windows 7 Ultimate
Memory: 3GB
Hard Drive: 250GB
CPU: 1.8GHz Dual Core
Bios Version: 3.0

Hi, please can someone help!

I cannot boot up my Acer Laptop, not even in to bios, it just freezes when I press F2 (prompt: press <f2>. to enter setup). I've tried ALT+F10, Delete, F8, changed hard drive/memory etc but nothing happens, it stays frozen.

It was working absolutely fine. The problem started when I updated the drivers and the apps Launch Manager/Touchpad from Acer.com. It suddenly went very slow. On restart it stopped working altogether. The Touchpad does not seem to be like it was before either, non responsive at times.

It sounded like that somehow the Bios got corrupted. So I downloaded the latest bios version 3.10 from the Acer website. I placed the files on an sd card because I didnt have any usb drives and restarted the pc. Kept the fn+esc pressed, then switched on the laptop. I kept the fn+esc pressed for about 15 seconds. Afterwards the laptop makes a long beeping sound and restarts the operating system, although still very slow.

When win7 started I clicked on the sd card device, and updated the bios from there (eg: without the sd card, pressing fn+esc doesnt work). I followed the prompts, it said not to do anything during this process. When it started it just displayed a blank screen, completely black. I again did the same fn+esc thing and it started.

Now it starts and displays the prompt: press <f2>. to enter setup, but never enters bios, or starts the laptop up until I have the sd card with the bios files installed and press the fn+esc keys.

What shall I do?

Any help would be highly appreciated.


See More: Acer Aspire Laptop Cannot Enter Bios? Please help.

Report •

#1
December 26, 2011 at 07:15:12
Bad idea to update the BIOS using Windows. It should really only be done when Windows is not running. BIOS chip may be damaged.

Report •

#2
December 26, 2011 at 08:25:44
Its quite strange, if I have a win7 dvd (havent tried other dvd's) in the dvd rom drive, then after a while the laptop boots up. But if there is no dvd in there, then it just hangs on the startup screen "Acer empowering people".

Once it starts up, everything works fine although it is slower than before and I have notices the trackpad is non responsive at times.

How can I sort this out please?

Thank You in advance.


Report •

#3
December 30, 2011 at 07:42:38
Just an update:

The laptop now works and boots to the operating system and to the bios.

I tried to check each component, memory, hard drive etc all ok. The problem seems to be the sd card reader.

I have inserted an 'empty' sd card adapter and it boots up fine. If I remove it from the laptop then it just hangs on the first screen. It wont even boot to bios without the card inserted, but works if it is in the laptop.

Its strange because the inserted sd adapter is also empty, meaning its just an adapter, there isn't a micro card inserted in the adapter, its just empty.

Anyway a bit of an inconvenience but it works.

Regards

www.youtube.com/iamtemur


Report •
Related Solutions


Ask Question