Access denied to External Hard Drive

Microsoft Windows xp home edition
January 7, 2010 at 12:07:41
Specs: Windows 7
Hi there, when trying to open my external hard drive, i get the following message, "Windows cannot access the specified device,path or file. You may not have the appropiate permission to access the item." I can open the external hard drive on my other computer without a problem. I can open other USB flashdrive on this computer, just not my external hard drive. It used to open without a probelm. Please can you suggest a way to fix this.

See More: Access denied to External Hard Drive

January 7, 2010 at 12:11:04
It's all about taking ownership of files & folders. Instructions to accomplish this is given at the link below - just ignore "Vista" mentioned in it & it will work in Win 7 too....


Report •

January 7, 2010 at 23:26:23
Hi There, Thanks for your reply. What i neglected to mention was that the PC where i'm having trouble opening the external hard drive is running Windows XP, i'm communicating from my other PC which is running Windows 7, and have no problems on this machine.
I tried the advice anyhow, but when i folllow the steps, in "My Computer" i can see the Device {External HArd Drive (F:)} and when i right click on the device, i can see properties, but no security tab in properties and therefore can't access advanced and change the rights. When i pull down the address bar i can see the drive, but when right clicking nothing happens. Strangley enough when i pull down and view the drive from the address bar, i can access the data on the drive, but still not from the "My Computer" screen.
Any advice will help.

Report •

January 7, 2010 at 23:58:57
You may try the following:

Open a Command Prompt with Admin Rights and type in the first line below and execute it and then type in the second line and execute it. That will give you the rights to access whatever folder you want to reach. For example; if you want to take control of folder named MyFolder on D: drive, simply put in D:\MyFolder in Path to folder\folder name below. You should leave blank spaces where necessary and before slashes.

cacls “Path to folder\folder name” /E /T /C /G Administrators:F

takeown /f “Path to folder\folder name” /r /a

Hope the above helps.



Report •

Related Solutions

January 8, 2010 at 04:15:17
Thanks SautCINI,
I'm still new to navigating my way around command prompts etc.
The drive i'm trying to access is called "External Hard Drive(F:)"

to get to command prompts, i went Start / Run /
typed in cmd and entered. Then the window with the black back ground comes up and I followed your suggestion above and entered the following:

cacls “Path to folder\External Hrd Drive” /E /T /C /G Administrators:F

and then pushed enter. I then entered the following

takeown /f “Path to folder\External Hard Drive” /r /a

and pushed enter, but still no luck.

Have i entered these comands correctly, if so, is there anything else i can try.

Thanks in advance

Report •

January 8, 2010 at 04:36:30
1) As I understand, you have not opened CMD with Admin privileges. That way the command prompt opens with normal user privileges, you need Admin privileges.

2) Path to folder should have been replaced with the drive letter followed by a :

In your case, type in the following: ( Your ext hard drive letter is F. This letter is not the F after Administrators below. )

cacls “F:” /E /T /C /G Administrators:F

takeown /f “F:” /r /a

To open a command prompt with admin privileges, go to start all programs, accessories, system and right-click cmd.exe and select Run as Admin

Hope this clarifies.

Note: This operation may be easier if you temporarily disable UAC.



Report •

January 8, 2010 at 06:21:17
Thanks SuatCINI,
Yes my profile is a Computer Administrator profile. I entered the first prompt which worked and the screen ran through what seemed to be all the information on the External Hard Drive, then when i entered the second prompt the following message was displayed.

'takeown' is not recognized as an internal or external command, operable program or batch file.

As a last try, is there any reason that i got this message i entered everything as suggested.

Thanks again for your help.

Report •

January 8, 2010 at 07:48:30
Try again after disabling UAC and rebooting.

By the way, Admin Profile is not enough. You have to open command prompt with Admin Privileges.

The message you get is not valid. I did both commands and they work.



Report •

January 9, 2010 at 03:13:07
Hi SuatCINI,
The PC i'm experiencin the probelm with is running Windows XP, and i can't see how to disable the UAC or open a command prompt with admin privileges. In Start - All Programs - Accessories - (i can only see "system tools" and no "system", and under "system tools" i don't see cmd.exe to right click on.

I did however log in as SYSTEM which apparently has more privileges than an Admin. I then followed the suggestions, but ended with the same message of:
'takeown' is not recognized as an internal or external command, operable program or batch file.
Strange, but i just can't seem to get it to take the command.

Never-the-less, i'll just go into the drive via the address bar from now on.

Thanks anyhow for all your help, it was very much appreciated.


Report •

January 9, 2010 at 03:43:19
I am sorry the OS you stated is Win 7. Look at your spec definition.

Besides this is Win 7 forum.

The commands may not work in Win XP.

Sorry for the confusion.



Report •

Ask Question