Solved 16GB Samsung Micro SD work in Sandisk players but not Win 7

March 5, 2015 at 15:48:14
Specs: Windows 7
I have nine 16gb Samsung micro sd. Using 3 in sandisk players work well, just as they should but will not format or write in windows 7. Tried all kinds of things to make them work with no success. Anyone have any ideas? Googled it got a few ideas but no good. Would maybe think they were bad but work fine in my Sansa and Sandisk players! tried sd formatter, gave me different reasons it could not do it but settled on write protection switch. Windows 7 gives various reasons (just can't do it)

message edited by randoh


See More: 16GB Samsung Micro SD work in Sandisk players but not Win 7

Report •

✔ Best Answer
March 5, 2015 at 19:40:50
Have you tried deleting the partition then creating a new partition. You should then be able to format them.

Also, how are you reading the cards in Windows 7? If using the player as a mass storage device you may have issues. You need to interface them directly to the computer. I use a USB to SD/MicroSD adapter to interface my cards.

My printer has a SD/MicroSD slot. When using cards in that slot, Windows 7 will not allow me to even delete any files from the cards.



#1
March 5, 2015 at 16:00:32
Are these cards formatted in FAT32 or NTFS? If not, I doubt Windows will recognize them. You'll have to use a 3rd party software program.

https://www.sdcard.org/downloads/fo...

message edited by riider


Report •

#2
March 5, 2015 at 16:12:43
riider -

I have used SD FormatterV4. It gave a couple reasons why it could not do it but then settled on protection switch on. Have never used 6 of them on Sandisk players the six are factory fresh.


Report •

#3
March 5, 2015 at 16:22:22
Windows 7 reads 14.4 gb but then tells me it must be formatted before use. So it reads but will not format. Out of Sandisk player (7) will read but not write or format.

message edited by randoh


Report •

Related Solutions

#4
March 5, 2015 at 19:40:50
✔ Best Answer
Have you tried deleting the partition then creating a new partition. You should then be able to format them.

Also, how are you reading the cards in Windows 7? If using the player as a mass storage device you may have issues. You need to interface them directly to the computer. I use a USB to SD/MicroSD adapter to interface my cards.

My printer has a SD/MicroSD slot. When using cards in that slot, Windows 7 will not allow me to even delete any files from the cards.


Report •

#5
March 5, 2015 at 22:25:38
I also have a USB to SD/MicroSD adapter, when used it is received but never shows in explorer or devices. I also thought it was a read only device. The Micro SD cards I have left are new, never used Samsung 16GB Class 6. In my Sansa and Sandisk I can do whatever I need to do with the three I used in these devices. I am trying to read the cards through a SD to Micro adapter (In fact a couple different ones) reboot it tells me the right info on the card. As soon as I try to do anything again I recieve a message it is full or some other crazy thing. I've tried every thing I can think of and whats at my disposal.

Report •

#6
March 6, 2015 at 06:04:14

Report •

#7
March 6, 2015 at 07:59:52
Use the adapter and look for the cards in Windows Disk Management. As riider stated above. If the format is not FAT or NTFS they will not show in computer or device manager.

If you see a listing in Disk Management, post all the information listed for that card.


Report •

#8
March 6, 2015 at 11:45:10
When first plugged in, disk management says 14.64GB Fat32 Healthy (Primary Partition).When I try to format it anyway it says cannot complete and changes from 14.64 raw to 14.64GB unallocated. When first put in layout-simple type-basic file sys.-fat32 status-healthy cap. 14.63GB free-100% fault tol. no overhead 0%. As soon as I try anything in any program everything goes south.

Report •

#9
March 6, 2015 at 12:20:20
riider have looked at post, have already come across them. No good. Thank you for looking them up for me!

Report •

#10
March 6, 2015 at 12:45:38
Machine keeps crashing with the write protection switch on. Plays fine with the switch off, makes me think my adapters are bad. Have to make sure it's not the adapters. Have to find a new one somewhere. Thanks for anymore ideas, Get back to you as soon as I make sure I have this basic taken care of. Thanks again! Snow bound love it!

Report •

Ask Question