Server '08 won't boot.

November 9, 2009 at 19:14:12
Specs: Windows XP, Custom
One of my Co-workers was using a server to copy a DVD using CloneDVD and Nero. Don't ask why she was doing it on the server?

Anyway she said that it locked up, everything but the task manager. So she Hard-reset the server. (Reset button)

Now it won't boot, it goes past the bios and searches for a boot record and then stops just displaying a black screen with a cursor in the top-left corner.

Any suggestions on how I can recover this would be great. It's a DHCP / Ghost Server, so it really would be pretty important not to lose the images stored on the HD.

See More: Server 08 wont boot.

Report •

November 9, 2009 at 19:35:35
I know it's a server, but my win2k3 server hangs if I don't unplug
my backup USB drive. Ya, a server with a USB drive for backup.
Don't laugh!

On a side note, CloneDVD + AnyDVD by chance? I think
AnyDVD installs drivers which may be the cause?

Report •

November 10, 2009 at 05:49:27
Found the Solution, I booted using the Windows Server '08 disk and chose the repair option. And of course lucky me it didn't even recognize a copy of server 08 being on the machine, hit next anyway and got an options screen, chose Command prompt I then went to c:\boot and found that it was a pretty empty dir, so I copied the boot directory from the Server '08 dvd to the C drive, then I ran bootrec.exe. and rebooted, now at this point instead of sitting blank it told me that the bootmgr was missing.

So I booted back to the cd and went back into the command prompt and typed the following:

bcdedit /export c:\bcd_backup
ren c:\boot\bcd bcd.old
rootrec /rebuildbcd

Then obviously it just re did what i had done previously but I figured that was a cleaner way to rebuild the bcd, and if I were to restart I would get the same problem again (bootmgr missing)

So before I rebooted this time since I have a partitioned drive I made sure that the partition with my server '08 install was set as the active partition by doing the following:

list disk
select disk # (My server '08 was on disk 0)
list partition
select partition # (Mine was on 1)

Then I restarted the computer and low and behold the world was saved....

Report •

November 10, 2009 at 07:56:51
could have done the same with recovery console and fixmbr / fixboot with a whole lot less effort and risk.

Question you have to ask yourself is what removed the boot record? Can you say infection?

Report •

Related Solutions

November 10, 2009 at 09:06:27
I didn't see a traditional recovery console option like WinXP and Server '03 has, or even anything similiar to the recovery options you get with WinVista. The serer '08 disk I have gave me just three options other then installing, Restore from back up, Memory test, and Command Prompt. The best I could get with the server '08 disk was the command prompt and using the "BootRec.exe" Initially I wasn't sure which switch to use, so I tried them all with out success. "/fixMBR" "/FixBoot" "/ScanOS" and what ever the fourth option was. That is when I ended up pulling my hair out, Then I think what really was the fix was using diskpart to make the partition the active one?

Report •

November 10, 2009 at 13:38:20
My bad. Thought I was still in the 2003 forum. Yep you are right 2008 relies more on backups then recovery console. Even 2003 recovery console can't mark the drive active. I usually use the newer version of fdisk but diskpart is also good.

I would still be concerned about how the active bit got turned off. This is not accessable by the file system so a crash should not of affected it. My concern would be you have a rouge program running on the server. Would not be surprising if you have folks using the server for other purposes.

Report •

November 10, 2009 at 14:49:26
I'm confused about what happened, but the concern about the server being a bot is very low, it sits on an isolated lan. I have no idea what my co-worker did to it.

Report •

Ask Question