Strange Stop 7B Problems

Microsoft Windows 2003 server - 5 users
May 23, 2010 at 06:04:52
Specs: Windows 2003 Standard SP2, Dual Xeon, 4 GB
I'm having a bit of a hard time with a customer's server. In the past, with 2003 and XP systems, I've been able to move a hard drive from an old system to a new one, run a repair install (in-place upgrade), and have a working system (needing just a few driver updates).

This one is different. The old server is a dual Xeon system from 5 years ago with a Silicon Image SATARAID controller; despite the "SATARAID" on board, the system was built using Win 2003 software raid. The new system has dual Xeons (just better ones) and an ICH10R drive controller.

I used nLite to build a "slipstreamed" install CD with SP2 and the ICH10R drivers from the vendor's site. The repair install on the old hard drive proceeds without a hitch, claiming to need 39 minutes but only taking about 25 to get to the "1 minute" mark and then restart.

That's where it goes bad. The "Windows 2003" boot screen appears briefly, showing the bar but not moving it even a single block, before dropping out to a Stop 7B error.

I used the slipstreamed install disk to install a NEW running system on a new drive in the same new computer, and it works marvelously. No Stop 7B.

Thing is, the drive now no longer boots in the old server either. The bar makes a couple of passes and then Stop 7B. As it contains what is, apparently, the only copy of the customer's Active Directory (and no, I didn't know that when I started), I'd like to get it up in either the old or new computer.

Things I've tried:

1. Half a dozen repair installs, including a repair install using the original (non-SP2) media in the original server with the F6 disk. None have worked.

2. Copying the contents of the old hard drive to a new one (formatted with that good install of 2003 I mentioned) and then repair installing on that drive with the others unplugged. I used ROBOCOPY, which took a while (about 170 GB of data) and the copy appears to have the same ownership, ACL, etc. as the original.

3. Booting to the Recovery Console and disabling the Silicon Image drivers (there appear to be three of them) along with the driver for a SCSI controller (used with a tape drive) which was in the old server. First time using LISTSVC and DISABLE. Tried a repair install after this too.

4. Double-checked the BOOT.INI file. Compared it to the BOOT.INI from the new build, and found no significant difference. Tried the new build's BOOT.INI anyway, and ran another repair install as well.

None of the above items have helped a bit.

As I understand it, when you run the repair install, the GUI appears after a hard drive boot; obviously, the hard drive is accessible at this point, and this is working fine for me. However, the NEXT boot fails. If it can boot from the installer driver set, why can't it boot from the installed driver set?


See More: Strange Stop 7B Problems

Report •

#1
May 23, 2010 at 06:15:33
Oh, yeah, one more thing... Safe Mode booting doesn't work either.

If it did, I'd go to Device Manager and remove all the old drivers from there. But I suspect if it did, it'd boot in normal mode and I wouldn't have this problem.


Report •
Related Solutions


Ask Question