RPC server unavailable

Microsoft Windows server 2003
December 16, 2010 at 11:19:03
Specs: Windows 2003 server x64, Xeon Quad 2,8Ghz / 16GB
Hey guys, I need some help with this.

I've got two Win2k3 x64 servers on the same network. Primary DC (server2) is working OK. Secondary DC (server1) was just reinstalled a few weeks ago after a hardware upgrade, and since about a week ago I'm having problems with it. First of all it won't replicate DNS from the primary DC. When opening DNS on server1 it says it's not available.
Secondly, I cannot remote access it. I reach the logon window, but when entering credentials and pressing OK it says "the RPC server is unavailable". I can log on locally though, no problem.
Thirdly, I cannot access any shares to or from server1. It's as if it doesn't exist on the network. I can still access the internet but no LAN resources. Obviously this is because of the DNS problem.

I've googled a dozen things and tried restarting TCP/IP Netbios helper, DNS server, remote registry etc. I've even uninstalled / rebooted / reinstalled the DNS server. I'd try uninstalling AD using dcpromo, but it fails because it can't reach the primary DC.
There is no firewall on the LAN between the servers. No firewall enabled in Win either. All updated from winupdate has been done. The servers both sit on the same subnet, in the same switch which is a new HP Procurve.

Server2:
IP - 192.168.20.2 / 24
GW - 192.168.20.254
DNS - 127.0.0.1

Server1:
IP - 192.168.20.1 / 24
GW - 192.168.20.254
DNS - 192.168.20.2 (I'd set 127.0.0.1 if I could access DNS to forward it to server2)

The problem is no doubt the o/s on server1, but I just can't figure out what...


See More: RPC server unavailable

Report •

#1
December 18, 2010 at 08:32:23
RPC error occurs mostly due to DNS issues,

Run nslooksup from command prompt, check whether u are able to connect to DNS server.


Report •

#2
December 20, 2010 at 02:27:17
You are correct. This issue appeared due to a DNS issue, the secondary server didn't replicate from the primary, so the DNS structure was all messed up. I'm not sure what solved it exactly, but today it's fixed and the replication works - so does the RDP login.

Still having the issue with network shares though, but I suspect that's a win x64 issue I've dealt with before.

Thanks for your input pbu80.


Report •
Related Solutions


Ask Question