Folder permission problem

January 11, 2010 at 07:33:33
Specs: Windows Server 2003 R2
Hello all,

I'm trying to run a an patch file on windows server 2003.

But when i do that, the patch file responded with the following:

"Please make sure you have the full access rights to the windows folders"

I am logged in as Administrator so i thought I had all the permissions needed, but apparently i dont.

I've tried running the patch on windows xp on my other computer and it worked. So i am sure the patch file is fine.

So I believe the problem is down to the permission settings on windows Server 2003.

I am a complete newbie on Windows Server 2003 so i have completely no idea how to deal with it. I also believe that the current permission settings are by default since i've never changed any settings.

Any help on this issue is greatly appreciated =)


See More: Folder permission problem

Report •

#1
January 11, 2010 at 08:14:12
A bit difficult giving the correct answer since I don't know the prerequisites, but I'd check if maybe you're on a domain controller and that you don't have domain admin rights. Go into AD users and computers and right-click your user account, click the member of -tab and see if you've got domain admin there. If not, add it. If you can't add it, you're not on a domain controller. Fairly easy way of finding that out.

Otherwise I'd guess someone before you has changed default permissions on folders, so just go through the system folders (windows, program files and documents & settings folders) and see if administrators have full access, or make it so.


Report •

#2
January 11, 2010 at 08:33:33
Thanks Phatsta for your quick response!

I've checked the "member of" tab and confirmed that domain
controller is on there.

I've also made sure i've full access to the 3 folders you have
mentioned ("full control" checked under security tab)

This seems a lot more complicated than i thought =(

Any thoughts?


Report •

#3
January 11, 2010 at 14:25:18
I think you got some bad advise. Your user account should not be a member of domain admins. This is a horrible idea as it gives any malware that might run under your daily account access to do anything it wants in the domain. Take your account out of domain admins. It is rarely a good idea. And you said you logged on as administrator so that account should have all the access you need.

I also would not go in and start changing permissions on system folders. It is that sort of advise that gets you into situations like this in the first place.

It is hard to say what the issue is. Does this patch run inside of the program? If so, what account does the program run under? It might be that the program runs under a different account than you log on with, and that account does not have the required access.

Can you call the vendor on this issue and run it past them?


Report •

Related Solutions

#4
January 13, 2010 at 12:31:42
Glen, what are you mumbling about? Since when don't you set domain admin rights to an admin account? It's even set by default. It's not a bad advise since it's the only way to perform several system changes and installations.

I'm not saying you should use the server admin account in your usual daily activities for example to surf with or whatever. As usual, best practice is to keep surfing to a client.

As for your problem hazel, what type of patch is it? Does it have a KB number like in a windows patch or is it an application specific one?


Report •

#5
January 13, 2010 at 21:17:14
Mumbling? Let see if anyone else thinks this makes sense. Quote "click your user account, click the member of -tab and see if you've got domain admin there. If not, add it. If you can't add it, you're not on a domain controller."

First of all you specifically said to add 'your account' to domain admin.

Since when don't I add domain admin rights to an admin account? Answer? Never. There is one account added called administrator. That account should be renamed. I'm not sure what you mean by 'admin accounts'. If you mean administrator accounts of servers, no - they are not added to domain admins by default.

Secondly, whether you can add someone to a group or not has nothing to do with whether or not you are on a domain controller. I guarantee you I can add all sorts of people to domain groups without being anywhere near a domain controller.

If you want to find out if the server you are on is a domain controller, use the command DSQUERY SERVER. That will list all the domain controllers.

So yes - I still think he got bad advise but hopefully he can get to the root of his problem.


Report •

#6
January 17, 2010 at 21:38:22
Thanks all of your replies ~
I've been out of town so i'm replying late.

Here's more info for what you need:

The patch does not run inside the program.
Its an independent .exe file to excute.

It doesnt have a kb number either since its a patch file for my ERP system but apparently my vendor does not have any support on this issue.

Thank you all for your help again =)


Report •

#7
January 19, 2010 at 05:25:54
Ok Glen, I'm not here to argue over details with you, take it easy. I don't know how you do things, and I'm not saying your way is wrong, but I do it like this when I set up a new domain:

1. Create a new admin account, it doesn't matter what you name it as long as it's not easy to guess, like 'admin' or your name or anything like that.

2. Set the same permissions on the new account as the default Administrator account, among there you have 'domain admin'.

3. Disable the default Administrator account.

Secondly, from what hazel wrote in his post I was under the impression he had 1 server, and if you only have 1 server it's 95% likely to be a domain controller or not a domain server at all. I took a guess, or a shortcut if you will (hence the "A bit difficult giving the correct answer since I don't know the prerequisites"), knowing that my advise was harmless. Obviously his problem was that he didn't have enough permissions and that gave him full permissions. Not that it helped, but at least you can rule that out.

If you still think I'm an idiot, please feel free to keep doing so, but keep it to yourself, alright?

Now, hazel. Can you install the ERP system locally, for example on a stand-alone XP computer, and try to apply the patch on that? What I'd like to know is if that patch actually works at all or not, if the problem is related to the server o/s or no matter what.


Report •

#8
January 19, 2010 at 18:07:57
Phatsta,

Thanks for your reply again.

The patch works perfectly fine on computers with XP.
So i am suspecting its the problem of windows server 2003.


Report •

#9
January 20, 2010 at 07:39:34
Okay well that's good to know. Post what groups the account you're using is a member of first of all.

Have you tried running the patch after a fresh reboot? I'm thinking there might be some open (ERP) files on the server that could be blocking the install.

Also post the full error message, if there are anything more to what you posted in the beginning, like error codes, paths, anything at all really.

Also check the event viewer if there are any logs from the install, and post what that says.


Report •

#10
January 31, 2010 at 23:44:51
Problem solved ! =)

All i did was right click and choose run as administrator.
everything works fine now.

Thank you all for your help!


Report •

#11
February 2, 2010 at 04:42:39
That's good news, but a bit weird since you were already logged on as an administrator... oh well. Happy that it works!

Report •

Ask Question