DNS Records Disappearing

Microsoft Windows server 2003 r2 standar...
May 24, 2010 at 07:43:11
Specs: Windows Server 2003
We have a closed network with no outside access. It consists of a single Windows 2003 Server (Standard with SP2) that acts as PDC, DNS, and WINS. No DHCP. There are currently 2 workstations joined to the domain. I had originally ran dcpromote and installed AD (which forced DNS also), and it seemed to work fine. I was then able to join the 2 workstations to the domain without any problems. Everything seemed to be working fine.

2 weeks later, I go back in there to help another admin who is having problems joining a new NetApp filer to the domain. After much trial and error and hair pulling, we find an error during the domain join attempt that says it can't find the _ldap SRV record. I looked at DNS on the server, and all of the default records were gone. It still contained _msdcs, and the domain.com folders, and an A record the admin had created to point to the new filer, but not much of anything else.

How could this have happened? What could have wiped out those records? It was working, I had joined 2 PCs to the domain. And everyone says they did not touch anything in DNS. I'm thinking the records got wiped out automatically somehow. Is there a way to find out exactly when the records disappeared, or what may have caused it? Maybe in a log somewhere?

And of course, how can I repair this? I am going to try netdiag /fix. I already went through and recreated all of the records I saw in a file in system32\dns\. But I am still unabel to join new workstations to the domain. I even tried removing the 2 workstations that had worked previously, and tried to join them again, and they fail.

Thank you for any help!!!

See More: DNS Records Disappearing

Report •

May 24, 2010 at 07:53:27
Post an ipconfig /all from the server for review

Did you first remove the machine accounts from AD before trying the rejoin?

Nothing in AD /DNS to remove those records automatically. Surely you have a server backup from after the install and before these records disappeared you can restore the dns files from?

Report •

May 24, 2010 at 08:14:06
Can't transfer data from there to here. But I will try to give all the info:
Server's IP is
Server is configured to use as DNS and WINS.
Workstations have other IPs in the same subnet, and are configured to use as DNS and WINS.

I did not remove the accounts from AD first, but that wouldn't matter. I get errors that the domain cannot be found, and the details show that they cacn no longer find the _ldap SRV records. Which makes sense because they have all gone missing!

No, no backups. We just started standing up this domain and server. We were attempting to get the filer joined to the domain when we noticed the missing records. The filer acts as the tape backup controller, so no backups were possible just yet.

Report •

May 24, 2010 at 09:38:38
Sounds like perhaps the records were never there in the first place and it was just a bad install of dns.

I would suggest dcpromo down the server, uninstall and reinstall dns and then dcpromo backup again. Make sure you are up on all the server service packs before dcpromo up again.

Report •
Related Solutions

Ask Question