Data Execution Prevention with VMWare Images - Please help!

September 4, 2012 at 12:11:41
Specs: Windows Server 2003
I recently installed General Electric's Proficy iFix software for work on a Windows Server 2003 VMWare image. After installing the software, I began receiving an error message saying that Data Execution Prevention has detected an error and requires Windows Explorer to close. This error occurred every 15 seconds or so and froze the entire desktop for a few seconds every time it happened - all icons disappear and all Windows Explorer windows close.
I tried everything that I have found on the internet, including modifying the boot.ini file to read "/NoExecute=AlwaysOff". I also tried changing the DEP settings through My Computer > Properties > Advanced > Performance > Settings. I tried checking each of the radio buttons, but nothing worked.
I uninstalled the software but still had the same problem.

I had one directory on my external hard drive that contained two different Windows Server 2003 VMWare images (I will call them Image A and Image B). Image A was the one that I installed the new software on and the one with which I first encountered the error.
When I booted up Image B, it received the same error! The two images are completely separate computers - Image B had no software installed or uninstalled or any other updates or major changes between the time that it worked and the time that the DEP errors started.

Then, I took an older copy of one of my Windows Server 2003 images, created before the Proficy software was installed, from another computer and placed it into a different directory on my external hard drive (I will call this Image C). When I booted this one up, the DEP errors were gone (or so I thought!)

Then, I left my computer and external hard drive running for the weekend. When I came back this morning, the DEP errors had returned! Changing the DEP settings does nothing, just as it did before. I don't know what to do - this prevents me from doing anything at all with the VMWare image because the error interrupts whatever I'm doing and closes all windows every 15 seconds. The only thing I am able to do is navigate through files and execute commands from the command line, and go to Start > Shut down to start/restart the computer (if I act fast!)

I read something about changing the DEP hardware settings in the BIOS, but from my understanding this doesn't make any sense in my case because the problem only occurs on my VMWare image which has the same physical hardware as my computer!

I am currently running a virus scan on my external drive - when it finishes, I will post the results of the Event Log to hopefully shed more light on the error message.

Any help is immensely appreciated - I am desperate and my deadline is fast approaching!
Thank you!


See More: Data Execution Prevention with VMWare Images - Please help!

Report •

#1
September 4, 2012 at 13:10:16
An update:
I got the error from the event viewer. The following Application Error keeps occurring:
Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Date: 9/4/2012
Time: 12:58:07 PM
User: N/A
Computer: COMPUTER-A
Description:
Faulting application explorer.exe, version 6.0.3790.3959, faulting module unknown, version 0.0.0.0, fault address 0x100014c0.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/even...
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 46 61 69 6c ion Fail
0010: 75 72 65 20 20 65 78 70 ure exp
0018: 6c 6f 72 65 72 2e 65 78 lorer.ex
0020: 65 20 36 2e 30 2e 33 37 e 6.0.37
0028: 39 30 2e 33 39 35 39 20 90.3959
0030: 69 6e 20 75 6e 6b 6e 6f in unkno
0038: 77 6e 20 30 2e 30 2e 30 wn 0.0.0
0040: 2e 30 20 61 74 20 6f 66 .0 at of
0048: 66 73 65 74 20 31 30 30 fset 100
0050: 30 31 34 63 30 014c0


And I also noticed an IIS error that continuously occurs. The software that I am using depends on IIS to run - could this be causing the DEP error? The IIS error is as follows:
Event Type: Error
Event Source: IIS Config
Event Category: Catalog
Event ID: 4275
Date: 9/4/2012
Time: 1:00:40 PM
User: N/A
Computer: COMPUTER-A
Description:
Error parsing XML file. Reason: An invalid character was found in text content.
Incorrect XML:
ErrorCode : 0xC00CE508
Interceptor : 14
OperationType : Populate
Table : MBProperty
ConfigurationSource : file:///C:/WINDOWS/system32/inetsrv/MetaBase.xml
Row : 0
Column : 0

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/even...

Hope this helps. Thanks in advance!


Report •

#2
September 5, 2012 at 12:11:55
I don't have much to offer on this, I'd be troubleshooting it from the ground up myself. However, a good place to start might be hijackthis. It will give you a list of changes to the system that are not default. If explorer keeps closing, you might be able to run task manager and run it from the new task function.

http://sourceforge.net/projects/hjt/

--
Andrew Leonard
BL Technical Services
Emergency IT Support


Report •

#3
September 6, 2012 at 20:05:46
If it has to do with DEP (Data Execution Prevention), you might wonna test this:

Change the attributes of the \boot.ini file to -r -h -s at the command prompt, by typing
attrib \boot.ini -s -h -r

Open the boot.ini file with notepad or something like that.

Change /NoExecute=XXXXX to /Execute

Save the file and reboot the server.


Report •
Related Solutions


Ask Question