Can't break Mirror

Ibm Xseries 220 p3-1ghz 128mb tower
February 8, 2010 at 00:25:45
Specs: Windows 2003 server, 2G
Hi

We are running Software based Mirrored drive (RAID 1). Our primary hard drive 0 has a bad block and I can't break the mirror (all of the 18.2G drive is mirrored and there are no spare spaces. I can't boot to the mirrored drive 1 without the original drive in place. I have tried creating a boot disc and pointing to drive 1 but I get the blue screen and it restarts.

Can anyone help as I need to boot off the mirror drive 1 and recreate another mirror set with a new drive.

Thanks



See More: Cant break Mirror

Report •

#1
February 8, 2010 at 02:18:59
Replace the bad drive, that should make it boot from the good drive. Then rebuild the array when booted.

Report •

#2
February 8, 2010 at 08:06:09
The bad drive is the primary not the shadow disk.
One bad block is nothing to worrry about or do anything about.

kiwi_hk
when you try to break the mirror in Disk Management what error do you get for it not demirroring?

What are the drive type? Sata/ide/scsi?

What message do you get when you boot the shadow drive alone? Or do you only get a flashing cursor in the upper left corner?


Report •

#3
February 8, 2010 at 16:57:12
When I try to break the mirro I get a logiical disk manager windows pop up saying the operation did not complete, check system event log for info. Event ID 7 (the device \Device\Harddisc0, has a bad block)
The drives are scsi and I read some where that I need some spare spaces to break the mirror I think, as both drives is mirrored completely.

When I try to boot from drive 1 I get the blue screen with lots or error and it reboots, if you want to know what it says I need to disable the auto reboot on error in bios "BOSD" I think.

Is my harddisc 1 also faulty?

Thanks


Report •

Related Solutions

#4
February 9, 2010 at 06:32:25
With scsi you have to either [depends on controller] set the drive you want to boot to scsi id0 or go into the scsi controller and set disk1 to boot [as oppossed to disk0 to boot as presently set]

Are you sure you are doing a software mirror?

Usually with scsi you have a raid controller and its doing the mirroring. Do you see one drive or two in Disk Management?

BTW there is no need for spare space etc to break a mirror.

Also the bad block error has nothing to do with breaking the mirror. It also is of no consequence. You will note it is blue informational. When you break a mirror you will get a ftdisk error.


Report •

#5
February 9, 2010 at 18:14:03
Yes it is using software raid and I see 2 hard disc in disk management as there is only 1 controller onboard with I scsi cable connected to the drive. I have even changed the scsi ID from 1 to 0 and I still need the faulty scsi to start it up. It won't boot from the other Hard discs if I pull the drive 0 offline and I get the error when I try to break the mirror.

Maybe HD 1 is faulty also.

I will let you know what the blue screen says next Wed-Thursday.

Thanks


Report •

#6
February 10, 2010 at 06:41:01
doesn't appear either drive is faulty.

OK, to force the mirror break, down the system and disconnect drive 1. Boot up only on drive0. Now you should see the ftdisk error

Down the system and only have disk1 connected as scsi id0. Via the bios boot the 2003 cd and do a repair install on disk1. Do all of the service pack updates.

disconnect the now drive0 id0

Put in a new raw disk1 at scsi id0 using a boot diskette or the 2003 cd partition and format the disk as bootable. Boot it to test.

This will make sure the disk has a master boot record.

Reconnect disk0 and set the second disk to id1. Boot the server and remirror the disks.

This will accomplish what you wanted to achive.

If you were wanting to you should be able to clear that bad block error by running chkds /r on the drive. chkdsk should mark the bad block as unusable.


Report •

#7
February 10, 2010 at 16:24:36
Thanks, I will try this next Wed-Fri and let you know.
If all fails I will have to reinstall everything and was thinking of getting a hardware raid to save me all this trouble next time.

Report •

#8
February 16, 2010 at 17:34:30
I just checked before I start, if I pull the SCSI 1 HD and try to boot on SCSI 0 it doesn't work, I need both HD in, so if the cd don't fix it I guest I have to reinstall everything.


Report •

#9
February 16, 2010 at 20:01:12
kiwi_hk

Just to reiterate, one bad block [assuming one cluster] is nothing to worry about or do anything about.

Running chkdsk /f should mark this as unusable and that's the end of the story unless more show up later. That would indicate drive platter failure and that does demand action.

Since you have been unable to break the software mirror in Disk Management [highly unusual], the only option is to force a mirror break.

This is simulating what would actually occur naturally ie a drive failure. That is pull the shadow drive.

But now you write:
"if I pull the SCSI 1 HD and try to boot on SCSI 0 it doesn't work"

I am assuming you mean it does not boot. I can only conclude you misidentified and pulled the wrong drive.

As a test pull [and by pull I mean pull the power connector only to make it easy] drive0 and see if drive 1 boots.

Hey one of those drives boot or the system would not boot.
They do not boot together. That is an impossibility.... unless this is not a mirror but a stripe set - Raid 0 [bad bad bad]

Can you post a screen shot of disk management on the web somewhere and provide a link? It does say MIRROR????
These disks do say they are dynamic not basic... right?


Report •

#10
February 16, 2010 at 20:39:57
Yes dynamic, It's ok, I think I have sort of fixed it?
The mirror is not working (offline?needs activate) because SCSI HD0 has bad blocks, so I assume it will not boot from SCSI 1 because it's not sync completely? or software raid is just not that reliable or SCSI 0 needs some date from SCSI 1 to start up because of this? but still I need it plugged in for it to start up in SCSI 0.
I went into the adapter SCSI utils and verified and mapped about 20 bad blocks on SCSI 0 (SCSI1 has no bad blocks) and tested it now and can boot on 1 x SCSI 0, I have put the SCSI 1 back in, broken the mirror and reactivating the HD and it is re-syncing the mirror now but failed with event view saying bad blocks in Harddisc 1, I check it in the utils and it had no bad blocks.

I will convert the SCSI 1 to basic disc and then dynamic and then reformat it and try syncing it again, if this fails I don't know what to do, maybe SCSI 0 is too badly damaged to mirror? Nothing in the event log said anything about SCSI 0 and it's healthy in Disk managment.

Kiwi


Report •

#11
February 16, 2010 at 23:44:45
Try to format it, scan disk it with no errors on SCSI 1, even tried moving it to SCSI 2, it just failed after I add mirror I think at about 25%.

NOw I only have 1 drive working and I am sure SCSI 1 is ok, is SCSI 0 has too many sectors to do a mirror on anything?

I can try getting another SCSI HD 1 and see.?


Report •

#12
February 17, 2010 at 17:50:21
Did you run chkdsk /f on scsi0?

I am not sure why you are spending time on scsi1 when its scsi0 that has the bad blocks. To remirror it should have just been a matter of making dynamic or importing dynamic disk and remirroring.

With the amount of difficulties you are having I am thinking you have other hardware issues.

How is the scsi cable terminated? By an active terminator at the end of the cable or is the last drive [scsi1 jumpered to provide termination]?


Report •

#13
February 17, 2010 at 18:25:30
Yes, it's is a working server, so everything is hardware configured. But I couldn't remirror it, so I reformated the SCSI 1 and now SCSI 0 has failed to boot saying \windows\system32\config\system error.
I think the SCSI 0 is going.
I will reinstall the server, do you have any ideas on how I can copy all my printer settings to a new server as it has about 20 printers on it used as a print server. I can see the files on the HD when I put a Windows PE disc in, but not sure if there is a way to copy all the printers settings I had since the system is no longer bootable and I don't think we can repair this system error since the HD is making a small squeeky noise now.

Report •

#14
February 18, 2010 at 09:11:12
Ideally you have a good backup with system state. If you reinstall a base 2003 install and then restore you should be good.

I think you have more than just a problem drive going on here. Bad or wrong scsi termination will cause drive errors and problems.


Report •

#15
February 18, 2010 at 21:57:56
There is no backup since is just a print member server and it has been fine for many years, I put the SCSI 1 on a identical machine and it won't mirror also, I think both hard drive must be on it's way out, I will try another drive to mirror on Monday, if it works then both drives is not reliable, but do you know any way to copy the printer setting files over to another server, this will save me time to reinstall 20 IP printers. As I said I can access the Hard drives files only but it hangs most of the time. I am not sure if there is a way to copy some folders over to restore my printers.

Report •

Ask Question