Un/installing HP printer, cleanly?

September 7, 2008 at 10:25:39
Specs: Windows 2000, Pentium II, 383 Mb
After following the instructions here:
I am unable to print. I can see a job being sent to the printer and then it is deleted.

Under Printers, it shows a printer icon as I was able to finish adding a printer successfully. But after I unplug the USB cable, restart the computer and plug in the USB cable again; I see the error message
"The drivers for this device are not installed (Code 28). To reinstall drivers, click Reinstall Driver."

Clicking Reinstall Driver, it is unable to locate the driver. I think that printer was initially not cleanly or correctly uninstalled. I've tried uninstalling (via Add/Remove Programs) and then installing again but with the same results. (I am unable to uninstall from the HP menu in the Start Up menu, it says that option only works for programs that are installed).

Any way to completely clean out all of the old HP files for a clean install?


See More: Un/installing HP printer, cleanly?

Report •

September 7, 2008 at 14:40:06
The "caution" at the beginning of the instructions is very important...hopefully you followed it.

If you don't have CCleaner, download it, install it (make sure NOT to install Yahoo toolbar), then run it...both the cleaner & the registry scan. Reboot, then try installing the printer software again.


"If my answers frighten you then you should cease asking scary questions" - Jules Winnfield (Samuel L. Jackson) in Pulp Fiction

Report •

September 8, 2008 at 19:41:20
You may simply need to plug into a different USB port, or you may have an IRQ sharing problem

See response 3 in this:


You never made any comment about my answers about what is probably the same printer 6? days ago.

It is very irritating to us when the person who originally posted never makes another post in a Topic (thread) after the original one because we never know if they even bothered to read the answers.

In case you didn't read the above when I pointed to it before, or now, you should be aware that those things are usually what cause problems with USB connected printers, particularly when you first install the software.
If you can't get the software installation to recognize the printer when you first install it, assuming the HP printer is powered on like it's supposed to be, one of those things IS the problem. If those things are not right when you try installing the software, you will probably have to un-install the software, then re-install it, after you have plugged the printer into a better USB port or fixed the IRQ sharing problem.

Whenever I have had problems with a HP printer after the software WAS working correctly, especially more recent USB connected ones, I have found it is a waste of time trying to figure out what is wrong and trying to fix things - that usually does NOT solve the problems. Un-installing ALL the software for it, not just the drivers, then re-installing it, is the fastest way to fix the problems.

Report •

September 27, 2008 at 04:18:42
Un-installing ALL the software for it, not just the drivers, then re-installing it, is the fastest way to fix the problems.

Thats what he tried to do you bloody idiot. Jeeze, do your replies ever make sense?

Medion MIM 2080
Toshiba T2130CT
Macintosh Performa 450

All working wonderfully.

Report •

Related Solutions

September 27, 2008 at 08:11:44
Intel 80486 / meisinscotland

Abusive language is not allowed on this site.
Think whatever you like, just don't state it in your post.
Your post with abusive language in it can be deleted, or if you keep it up in other posts as well, you can be banned from posting on this site forever.

Bobbie did not provide enough info in his posts, and no feedback to my suggestions, in this thread, and in his previous one:

I know from experience with HP printers
that if you un-install just the drivers and re-install them, that usually doesn't fix the problem.
It is not clear whether Bobbie tried un-installing all the software related to the printer or not.

I know from experience with USB connected printers, multifunction printer/scanner/etc. devices, and scanners, etc. that it can make a difference which USB port you use, and that there may be an IRQ sharing problem you need to fix.
Bobbie made no comment about whether he checked for those possible problems.
Either of them can cause the error messages he got.

Report •

September 27, 2008 at 09:55:09
By the 'Subject' field of my post and my original post where I wrote "I think that printer was initially not cleanly or correctly uninstalled." it is clear that I have been trying to uninstall ALL the files.

As stated, I have looked at the IRQ and USB ports (although this was not my issue) and found no problems as I had suspected.

Report •

September 27, 2008 at 10:15:50
I did try posting to this thread but my post got lost somehow. In the post I stated that I had found no problem with the IRQ but reinstalled the USB controller drivers just in case.

I also wrote the following (and yes I already knew how to look for .inf files):

I've tried uninstalling and re-installing several times but it still cannot print. I've used CCleaner but still there is not a clean uninstall because when I try to install again via Add Printer, in the wizard it says a driver is already installed for the printer and I have to option to replace or use the existing one. I've tried both options.

I've tried installing without the printer plugged in, plugging in during installing and plugging in after installing.

I've also taken a look at:

But neither solution works. In Solution One, after step #9 I get " The installation failed because a function driver was not specified for this device instance" when it tries to install oem1.inf and the same occurs in Solution Two after step 8 when it tried to install usbprint.inf

Any hints? Time to switch to Linux perhaps? :P

Report •

September 27, 2008 at 10:30:09
Also wrote in my original post, "Any way to completely clean out all of the old HP files for a clean install?"

I have been very clear and specific about what I was looking for. Although someone may choose to go off on tangents in lengthy posts about possible related issues and their personal experiences, the poster is not obligated to respond. There are time and physical limitations to how much I can respond.

Report •

September 27, 2008 at 12:04:17
That's more like the feedback I needed to see.

"I did try posting to this thread but my post got lost somehow."

Maybe you forgot to click on "Confirm...?"

Have you tried a different USB cable?

Did you check the current volatges in your bios Setup? - +5v must be within 10% of it's nominal value.

HP used to have a HP software cleanup utility, at least it did a couple of years ago - it is supposed to remove everything to do with all HP software - but I don't know if it's still there. You could try searching for that.

If you don't find that, or if you do and it doesn't help.....

If the software is installed by Windows Installer, which is the case for a lot of more recent software, you could try this.

Go to the Microsoft web site and find the "Windows Installer Cleanup Utility", download it, and install it.

You could install the software as far as it will go - in most cases you leave the USB cable unplugged until you are prompted to insert it - or if the software is already there....

Run the Windows Installer Cleanup program, find the listing for the HP printer software, and delete the entry. At the very least that is supposed to de-activate anything active to do with the software, by using the original Windows Installer information - it removes the entry(ies) for the software in Add/Remove Priograms - it may even remove the files originally installed.

Then reboot and try installing the software again - in most cases you leave the USB cable unplugged until you are prompted to insert it - the printer's power probably must be on when you plug in the USB cable, even if it can turn on automatically once the software has been installed.

"when I try to install again via Add Printer, in the wizard it says a driver is already installed for the printer and I have to option to replace or use the existing one. "

If Windows keeps finding the printer drivers automatically after you have un-installed it's software, obviously uninstalling the HP software and using CCleaner didn't remove the *.inf file(s) for the drivers, and possibly the driver files.
- delete the printer in Control Panel if it is still there after you un-install the HP software, if you haven't already done so.
- you may need to delete the *.inf file(s) for your model. Search for *.inf files containing your printer model number, or the model series number - look at the ones you find - the date of it may be a clue - confirm that it applies to your printer before you delete it - if you not sure, copy it(them) to someplace other than in the Windows folder, delete the *.inf file in Windows.

"....the poster is not obligated to respond."

Of course, but if you don't, how is anyone supposed to know you even read the responses?

Report •

September 27, 2008 at 13:13:35
Better still, search for the *.inf files that mention your printer model or model series, confirm it's for your printer, and print it before you delete it. The files mentioned in the *.inf files are the ones you need to delete if they are still there, and you need to delete any lines mentioning them in the registry.

Report •

January 7, 2009 at 04:05:29
Bobbie, just specially registered to try to help you. I recently found one utility which "cleanly remove" printer drivers.. since I also required to make clene delete.. maybe it will help you.. try it.

It called "Driver Deleter" by Kyocera. Works will oll type of printers, HP as well.


Report •

March 18, 2009 at 12:10:16
If you go to printers and faxes click on file go to server properties you will see a drivers tab. Click on the drivers tab and you an uninstall any printer driver you want.

Report •

March 18, 2009 at 13:18:51
We haven't heard from Bobbie since Sept 27 / 2008.

99% of the time, if we don't hear from the person who originally started the Topic within a week or two since he or she last posted, we never hear from that person again, at least not for that topic.

Report •

March 18, 2009 at 15:16:17

What service pack do you have installed in Win2000? If you don't know, right click on My Computer and choose properties. SP should be listed there.

You need at least SP3 to utilize USB 2.0. I recommend running the latest SP, which is SP4. There are also post SP4 updates.


Report •

Ask Question