FLTMGR.SYS bsod on bootup

(oem) ?
February 26, 2009 at 02:06:25
Specs: Windows 2000pro, AthlonXP, 512MB RAM
I was unable to boot my PC at all until I removed a Tamarack USB driver file (USB2400.dll) from the System32 folder. It has helped a little, but now I get this bsod error:

STOP: C0000263 {Driver Entry Point Not Found}

The \SystemRoot\System32\Drivers\FLTMGR.SYS device driver could not locate the entry point IoGetDeviceAttachmentBaseRef in driver Ntoskernel.exe

After I saw this, I booted Windows in safe mode and got to a desktop. Unfortunately I could not find anything out of the ordinary and nothing immediately outstanding. Nothing had a yellow exclamation mark in Device Manager (of course in safe mode, not all drivers are loaded). Not knowing what to look for or what to do next, I rebooted in normal mode, but straight back to the same bsod. So, progress has been made, but I'm not quite there yet.

What causes the FLTMGR error? What does this file do? What would hinder it from operating properly?

See More: FLTMGR.SYS bsod on bootup

Report •

February 26, 2009 at 06:07:43
Below is a link to the same error in server 2003.

I suggest you run a registry cleaner from safe mode and see if that won't remove the offending driver mismatch. Try Cleaner's registry module.


Report •

February 26, 2009 at 08:27:32
Thanks. I can now boot into safe mode, which bypasses most drivers... therefore it must be one of the bypassed drivers that stops Windows from booting normally. The problem is finding out which one.

Report •

February 26, 2009 at 09:01:09
Running chkdsk in safe mode may find the discrepancy.

Could simply be an orphan file in the registry hanging up things too. Just run CCleaner registry module and see what happens.

You said you removed a driver. The pointer is still there. Removing the pointer may clear up the problem. That is what registry cleaners do.

The reason for the mismatch may be due to multiple instances.

Report •

Related Solutions

February 26, 2009 at 12:15:13
OK I ran CCleaner and it found and fixed 78 issues. I then rebooted but it just went straight back to the same bsod.

Report •

February 26, 2009 at 13:45:02
You ran the registry module? Not that it will make any difference with your current issue but run the cleaner module too.

Report •

February 26, 2009 at 14:07:32
OK I know you are trying to help me and I know it's a tricky problem. However it's my main computer, my main scanner PC and my main file server, and basically I just need it working. This problem has dragged on for three days now and I have to take drastic action. I've backed up My Documents and I must now reinstall Windows. Yes it's time for the big one. If it is a hardware issue we'll know soon enough when the new installation hits a bsod too!

Report •

April 7, 2009 at 10:09:58
Put your hard drive as Slave drive D: in another PC. Log on as administrator. Click My Computer then Right-click on drive d: and click propertys / security. Add Everyone if it is not there. Then check all the boxes 'allow'. Then click advanced. Check box 'Reset permissions on all child objects...'. then 'Apply'. Wait until the process completes. Takes a while. Return your drive to Master and return to original PC. That's it!

Report •

May 20, 2009 at 10:58:46
I had the same IoGetDeviceAttachmentBaseRef "entry point not found" problem, and I spent DAYS trying to fix it. I hope I can save someone else the trouble.


Install update rollup 1 for Windows 2000 SP4. See KB891861 for details.


This link will tell you that IoGetDeviceAttachmentBaseRef is a new function added in the rollup:


At some time, your computer installed a new or updated driver that makes use of this function. If you haven't installed the rollup, the function doesn't exist, so you get the BSOD.


At one point I tried ErnieJay's suggestion, and the result was that it BROKE the borrowed PC, which is now stuck in a login-logout loop! This apparently can happen when the PC discovers it has two disks with valid operating systems. For some reason known only to Microsoft, it changes the registry to point to the second disk, and when you remove it... poof.


Report •

September 7, 2009 at 20:11:07
In reference to:
Response Number 8
Name: Johnny Blue Screen
Date: May 20, 2009 at 10:58:46 Pacific

Installing update rollup 1 for Windows 2000 SP4 (KB891861) worked like a charm for me. Many thanks!

Report •

Ask Question