Win 10 Camera App Won't Run, Skype Works OK

Dell / Xps 8930
February 18, 2020 at 20:09:51
Specs: Windows 10, I5-9400
I installed a Logitech C930e webcam. It works fine with Skype, but the Win 10 camera app crashes every time.

I updated the firmware via the Logitech website and I uninstalled/reinstalled the camera via the device manager. No help.

The following image shows shows that the camera is set to work with the Camera app and also shows the error that pops up whenever I try to run the camera app.

Any suggestions would be most welcome. Thanks!

https://imgur.com/a/dx31SSb

message edited by DerbyDad03


See More: Win 10 Camera App Wont Run, Skype Works OK

Reply ↓  Report •

#1
March 4, 2020 at 00:28:19
I too am having this issue!

I would think it's an issue with the camera too, but like I said the camera works fine in Skype and using the tools in the SDK. Also, I tried the camera on a Samsung laptop with Windows 10 10240 on it and it worked fine there too. So, it is something with the either my video card drivers, Nivida, latest drivers for Windows 10, Windows 10 itself or the Intel drivers on my chipset/cpu.

I even changed my MB from the Z87 chipset to the Z97 chipset and from MSI to ASUS and still the same issue.

Other thing I have noticed, is when the system comes out of sleep I get the "looking for you" icon, but the camera is not activated, so thinking it is more Intel driver issue related.


Reply ↓  Report •

#2
March 7, 2020 at 07:16:36
OK, strange things happening.

I was getting ready to call Dell Tech Support about my camera app issue (new computer, under warranty) so I wanted to have a screen grab of the Camera app error. I tried to open the Camera App and got the same error as every other time. I took a screen grab, saved it to a file and closed the app.

As I was dialing Dell, I tried to open the app one more time and it worked. I hung up the phone and tried it multiple times, sometimes with other apps open, sometimes without. I was wondering if there was an incompatibility with the other apps that I normally use. That doesn't seem to be the case as I can't get it to fail anymore.

It might make sense if it had started working after an update, but I'm talking about a difference of about 30 seconds between error and no error.

Maybe I scared the app by dialing Dell's number. Could they be monitoring me? :-0

message edited by DerbyDad03


Reply ↓  Report •
Related Solutions


Ask Question