USB device not recognized - Error Code 43

February 4, 2019 at 00:16:40
Specs: Windows 10 Pro, AMD Phenom 2 X4 B95 / 2 GB DDR3
when I plug USB flash drive into back ports of the PC, it works fine. But when I plug the same drive into front panel, it shows USB device not recognized. A few weeks ago it was working absolutely fine.
When see in device manager it shows a yellow mark on the device and the device status shows an error code (Code 43) see https://imgur.com/eKAnTqB
I have tried 3 different USB drives and a USB scanner but same result. All works fine at the back ports.
Kindly help.

See More: USB device not recognized - Error Code 43

Report •

#1
February 4, 2019 at 00:38:11
blow in the port/usb-stick, uninstall the driver then re-install it again by plugging the device back in

worth the try right :D

i5-6600K[delid]@4.7GHz/4.4GHz cache/@1.395v LLC=6 | 2x4GB Crucial-DDR4-2400CL17@14-15-15-28 1T 3000MHz@1.4v | MSI Armor RX 570 4GB@1410Mhz core@1.2v/1920MHz


Report •

#2
February 4, 2019 at 01:03:00
Try to Update BIOS.hope its work.I am getting this exact same issue. This has started happening in the last few days.you may need to try other methods below.
https://dailytechposts.com/unknown-...

Report •

#3
February 4, 2019 at 03:16:31
Here is the new state, Drive showing in device manager, but not showing any partition in My PC and in Disk Management. https://imgur.com/FKTXs8k

Report •

Related Solutions

#4
February 4, 2019 at 04:41:21
If it is only one front port then it is possible that there is a physical problem with the port itself. If it is two or more ports then it is not the port but something else.
If the front ports are run through an internal hub then it is a problem with the hub or its driver in the system so as mentioned, delete the hub or port in Device manager without deleting the software, then restarting the machine to 'discover' and reinstall the device. If this does not work then go to the manufacture's web site (system mfg or board mfg) and download the latest drivers starting with the chipset driver and looking for anything else related to the USB ports, USB expansion chip, or USB hub and install.
The final possibility is with the cable from the front ports to the motherboard that have come partially loose or rubbed through and are grounding on the chassis somewhere.

And don't forget that just restarting the machine may fix many small problems that creep up over time. Windows 10 does something different from earlier versions in that it tries to save many states when shut down and started BUT when you invoke the "Restart" option, these are forgotten so when we refer to restarting, we do NOT mean shutting down and starting up again. Use the Restart option in he 'Start' options menu.

You have to be a little bit crazy to keep you from going insane.


Report •

Ask Question