Solved Secondary HD always spending 100% time processing reques

Wd Caviar black 1002faex 1 tb 3.5" inter...
June 13, 2017 at 21:25:07
Specs: Windows 7, Intel i7/12 GB RAM
Hi everyone,
I have Windows 10 64-bit, with two hard drives, one SSD for drive C which contains Windows and a SATA for drive D for files. Within the past week, and I don't believe there were any Windows updates or any new software installed, but according to the Task Manager the D drive is almost always at 100% of time spent processing reading and writing requests, so it slows the computer down to a crawl even during initial booting. I isolated the issue to something with the D drive because I disconnected it and the computer runs fine. The C drive always seems to be operating normally.

I attempted a clean boot and I tried booting in safe mode, and the problem persisted. I checked for any processes in the Task Manager, and there were no unusual processes as far as I could tell, and when I disconnected the D drive the computer runs fine. When I reconnected the D drive the problem returned. I also tried uninstalling Skype, because that apparently can cause some conflicts with Chrome, and I ran a malware scan with the Microsoft Malware removal tool which returned no results.

Does anyone have any suggestions?

Thanks


See More: Secondary HD always spending 100% time processing reques

Report •

#1
June 13, 2017 at 22:01:46
✔ Best Answer
Shot in the dark says it's hardware related, and the drive is starting to have difficulty reading the data. Make sure anything you want to keep on your D: drive is backed up to something before the drive dies.

The troubleshooting suggestion is to open Resource Manager, and see which files are taking a long time to access, and which program is requesting so much I/O.

How To Ask Questions The Smart Way


Report •

#2
June 14, 2017 at 21:32:15
Thanks for the response. I did attempt something else, I put the D drive in an external enclosure, there was some initial slowness of getting access to the drive but it's possibly just from running drivers to install this enclosure which I hadn't used in Windows 10 before. Otherwise it looked like the drive was ok, but I am running chkdsk on it right now, but it's been stuck on Stage 2: Examining File Linkage for at least an hour or two.

I'm going to give it some more time to hopefully finish, it did complete Stage 1 with no bad file records. But I might have to consider getting a new drive, this one is at least 6 years old I think.


Report •
Related Solutions


Ask Question