Questions about Windows Firewall rules

August 19, 2019 at 22:33:35
Specs: several
In Windows 10 Home from August 2016, Firewall has a long list of
programs that it can block or allow, incoming or outgoing, on a page
titled "Allow apps to communicate through Windows Firewall". The
list has checkboxes for "Private Profile" and "Public Profile". None
for "Domain Profile".

Is that because Windows 10 Home can't connect to a domain?

If so, does that mean that all the entries in the Advanced settings
for Inbound Rules and Outbound Rules that apply to the Domain
Profile are nonfunctional? So it doesn't matter how they are set?
And I can completely ignore anything to do with Domains?

I had another question, but I think I found the answer while
writing the first question. I want to set the Firewall so that
EVERYTHING is blocked except for the Edge browser, both
Inbound AND Outbound. From past experimentation, I think
only about five Inbound Rules and five Outbound Rules are
needed, three "Core Networking" and two "Microsoft Edge".

What I wanted to know is how to change the overall rule from
allowing Outbound communication unless a rule is set, to
blocking Outbound communication unless a rule is set.

It appears that I can make that change in the dialog box that
pops up when I click on "Windows Firewall Properties" on the
first page of the Advanced section. Tiny little link, easy to miss.

Please let me know if it looks to you like I've misunderstood
anything.

-- Jeff, in Minneapolis

message edited by Jeff Root


See More: Questions about Windows Firewall rules

Reply ↓  Report •

#1
August 20, 2019 at 19:05:13
You need the Pro version to join a domain. And you should stop using Edge.
https://www.forbes.com/sites/daveyw...
https://www.techrepublic.com/articl...

message edited by riider


Reply ↓  Report •

#2
August 20, 2019 at 21:16:28
riider wrote:

>You need the Pro version to join a domain.

So, that means I can ignore the Domain settings in
Windows Firewall?

> And you should stop using Edge.

You should say why. The link suggests that the problem
you see is Smartscreen, which I have always turned off
for exactly the reason the article talks about.

-- Jeff, in Minneapolis


Reply ↓  Report •
Related Solutions


Ask Question