new exFAT disk issue

January 20, 2020 at 07:33:53
Specs: Windows 10, 8GB

Below is my new disk, which I found to be formatted in exFAT

There's one issue: the total size reported by CHKDSK is wrong
( half the size of the real value, see the DIR command)

There's one remarkable configuration: the "allocation unit"
is 1 megabyte. That means that I have 1 megabyte clusters ?!
That's not good .. way, way, way too big.


C:\Users\user> chkdsk D:
The type of the file system is exFAT.
Volume Serial Number is 3655-09D7
Windows is verifying files and folders...
Volume label is D13.
File and folder verification is complete.
Windows has checked the file system and found no problems.

3519025152 KB total disk space.
128907264 KB in 29789 files.
4167680 KB in 4070 indexes.
0 KB in bad sectors.
2048 KB in use by the system.
3385948160 KB available on disk.

1048576 bytes in each allocation unit.
7630852 total allocation units on disk.
7500894 allocation units available on disk.

C:\Users\user> dir D:
Volume in drive D is D13
Volume Serial Number is 3655-09D7

Directory of D:\

27/03/2018 13:05 668.993 Install Discovery for Mac.dmg
05/04/2018 16:21 583.528 Install Discovery for Windows.exe
18/01/2020 17:25 <DIR> temp
18/01/2020 17:27 <DIR> mybackup
2 File(s) 1.252.521 bytes
2 Dir(s) 7.865.257.426.944 bytes free

C:\Users\user>


See More: new exFAT disk issue

Reply ↓  Report •

#1
January 20, 2020 at 11:37:51
Have you tried reformatting it?

Is this a thumb drive, if so is it a name brand or some cheap Chinese brand?


Reply ↓  Report •

#2
January 21, 2020 at 02:27:43
I know how to format, note that that isn't the question

The drive is a Western Digital My Book with 8 Terabyte, not an 8 Terabyte thumb drive :)


Reply ↓  Report •

#3
January 21, 2020 at 02:52:04
"I know how to format"
Right click on the drive > Format.
Select NTFS.

Reply ↓  Report •

Related Solutions

#4
January 21, 2020 at 03:00:37
Do you understand the question in the thread ?

Reply ↓  Report •

#5
January 21, 2020 at 03:06:16
Apparently not, can I have the simple explanation please.

Reply ↓  Report •

#6
January 21, 2020 at 08:15:01
I think THX 1138 (#1) was suggesting that reformatting it might happen to fix the problem, rather than questioning your abilities.

Always pop back and let us know the outcome - thanks


Reply ↓  Report •

#7
January 21, 2020 at 09:04:53
I'm not sure on that, as I think he perfectly knows his answer is way too simple.

Anyway, I think I have found some answers. The problem of this thread is Mac users. Because they exist, Western Digital needs to have disks formatted in a file system that is also used by the 1% users know as "Mac users". Well, if they have a USB connection anyway.

So, they need to opt for something else than NTFS, but FAT32 is found to be crap, so they have chosen the newer version of FAT, which could have been called FAT64, but they decided to call it exFAT.

It's crap, and the only reason of existance is because it is better than FAT32 (what isn't), and because non-Windows machines (including Apple) can use it. It's a fragile, non-journalling file system, that should be avoided where possible.

Even Windows 10's CHKDSK cannot work with it, as is shown above. It cannot get the total volume right, and I don't think the cluster size is reported correctly. Advised cluster size (by NTFS that is) for disks between 2 and 16TB (which is mine), is 4K. Not 1 megabyte.

But, carry on discussing how to format a drive.


Reply ↓  Report •

#8
January 21, 2020 at 11:01:15
"I'm not sure on that, as I think he perfectly knows his answer is way too simple."

No, I was not questioning your abilities, and I'm not sure how me asking if you re-formatted it was taken that way.

Personally, if I had this issue, that would have been the first thing I would have tried. I would have also posted that I did.

"not an 8 Terabyte thumb drive"

Yeah, I got that. But there are drives out here being advertized as such even though they're not. People are hacking the firmware to make a smaller drive look larger. That's the reason I asked. People who don't know better fall for this.

But, carry on being snarky to the people who are trying to help.

message edited by THX 1138


Reply ↓  Report •

#9
January 21, 2020 at 16:03:10
"Do you understand the question in the thread ?"

You didn't ask a question, all you did was post your findings.

You apparently don't like the fact that the HDD is using the exFAT format. You're obviously not a Mac user so exFAT is unnecessary, so the way to "fix" the HDD is to re-format using NTFS. So in the immortal words of Jules Winnfield - "If my answers frighten you then you should cease asking scary questions." https://www.youtube.com/watch?v=O-n...


Reply ↓  Report •

#10
January 21, 2020 at 21:02:53
If you do not like the answer to a not quite asked question and all other answers do not exist or will not help then either take the advice OR not but if not, then politely thank everyone and walk away.

You have to be a little bit crazy to keep you from going insane.


Reply ↓  Report •

Ask Question