Solved Impossible to format a USB stick

Gigabyte / Ga-78lmt-s2p
July 8, 2018 at 02:37:34
Specs: Windows 10, 8gig
I have not had to format a USB for ages but this week I had an occasion to spring-clean my store of sticks and I could not format one of them. I kept getting the message "Windows is unable to format this USB" (or words to that effect). The only way I can achieve this is to use a partition manager programme. I have searched the net for a fix with no luck.. To the best of my knowledge my machine does not suffer from any of the symptoms mentioned in nearly all the solutions.

My latest effort was to disable the USB/SD write protection in the registry Thus:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies

I never had this key so I had to:create it thus:
New > Key > Storage DevicePolicies
Then:
New > DWORD (32bit value) name it WriteProtect
Then 0 to disable

There may be a problem here because I don't have that statement in the registry menu, I have a 64 bit system and the menu does not make provision for that so I used the 32 bit entry, needless to say I still can't format a USB.

What now? All suggestions and help will be appreciated.

Regards


See More: Impossible to format a USB stick

Reply ↓  Report •

#1
July 8, 2018 at 06:14:36
Ewen

The key you mentioned along with the two in ControlSet001 and ControlSet002, do not necessarily exist and shouldn’t be created as it is probably a different issue.

It can be caused by malware, is your machine clean? If not run your anti programs.

Another thing that sometimes cures it, is to plug in your device, right-click This PC > Manage > Storage > Disk Management, then right-click the drive graphic of the device and select Change Drive letter, then change it to one nearer the end of the alphabet.


Reply ↓  Report •

#2
July 8, 2018 at 07:32:39
BurrWalnut thanks for your fix... my system is clear according to my AV and unhappily your fix never worked, but thank you for your interest

Regards


Reply ↓  Report •

#3
July 8, 2018 at 10:46:30
✔ Best Answer
If it's only one stick, suspect the stick.

Try this. I put what to type in quotes.

In a command prompt: "diskpart."

Then "list disk". This will bring up a list of all your drives. Find the one you want to format.

Then "select disk #" -- # being the drive you want to format.

Then "clean"

It should completely wipe the partition table. You can then go into disk management and create a new partition.

message edited by DanJ


Reply ↓  Report •

Related Solutions

#4
July 9, 2018 at 06:26:14
Warning, be very careful of using commands that include drive letters. Drive letters may not necessarily correspond with what you think. Possible to delete the wrong drive.

If you are housekeeping then just enter Disk Management and delete the partition on that drive> highlight the drive in question> right click that drive and select to delete volume> select Yes. Then Create a new volume (partition). Then format that volume. You c an name the volume (partition) at that time.


Reply ↓  Report •

#5
July 9, 2018 at 19:12:01
Thanks to all the respondents, this is the site where I got the Registry fix https://www.anysoftwaretools.com/fi... needless t say it never worked. I have since used two month old backup and I still have the problem. I also used DanJ's Diskpart method which did work but it is time consuming so I am back to using my partition programme to format which I only do infrequently.

Regards


Reply ↓  Report •

Ask Question