I can't get past the spinning diamond. Is just stuck there.

November 10, 2018 at 06:07:25
Specs: Windows 10
I get the game loaded. I get to pick which saved game I wanna play. I do that and it goes to the loading screen. Then thats where it stays stuck. It won't get past it. I let it go for 45 minutes last night. Please can someone help me. This game worked just fine a few days ago. Plus I've done nothing different besides putting a few mods in. I've also done a few things that google showed me and its still not working. PLEASE HELP (i'm on windows 10)

See More: I cant get past the spinning diamond. Is just stuck there.

Reply ↓  Report •

#1
November 10, 2018 at 13:15:27
Just for the record, i'm talking about the game Sims4

Reply ↓  Report •

#2
November 10, 2018 at 15:43:39
I don't know this game; and also I'm not running win-10 (fortunately...)

However I dun a wee google trawl (search) using the words/string:

sims 4 windows 10 won't start

It seems you're not alone with the problem.

Check this link to see the assorted solutions - of which there are many...

http://tinyurl.com/yarphho3


Reply ↓  Report •

#3
November 11, 2018 at 06:52:25
I didn't think anyone played Sims anymore. Did the problem begin right after installing the mods? From the Sims4 help forum:
"A helpful first step in diagnosis is to pull out all your CC and Mods and try again. Often, a CC conflict especially can be causing this."

https://forums.thesims.com/en_US/ca...


Reply ↓  Report •

Related Solutions

#4
November 22, 2018 at 01:58:42
A helpful first step in diagnosis is to pull out all your CC and Mods and try again. Often, a CC conflict especially can be causing this.

If you don't have any CC or Mods to pull out, try this set of steps to see if clears things up:
1. Origin > right-click The Sims 4 > Game Repair
2. Move (not copy) Saves, Tray, Mods, Screenshots, and Custom Music folders and the Options.ini file to your desktop. Delete the Scratch subfolder from inside Saves.
3. Delete the rest of the The Sims 4 folder from your Documents > Electronic Arts folder.
4. Start the game, and exit the game. Now you have a fresh Documents > Electronic Arts > The Sims 4 folder.
5. Copy all the folders and the file back and start the game again.

Hope this helps.

message edited by Piter


Reply ↓  Report •

Ask Question