Solved Help with Orical's Virtual Box and installing an Upgrade OS.

May 15, 2016 at 12:00:18
Specs: Windows 10, Intel i7
I am using Oracles Virtual Box, 5.0.20 and Windows 10, 64 bit is the host. I am also using the Virtual Box guest additions. I have loaded several operating systems with no problems. However, I am having one problem that I hope someone out there can help me with that I can not find in Oracles instructions. I am having issues with loading Windows 7 64 bit "Upgrade". Because the Windows 7 disk is an "upgrade", Windows 7 wants to see XP on the virtual hard drive so I can type in the Windows 7 product key. No XP in the virtual drive means the product key is not found. I have already tried loading 7 on top of a XP virtual drive and I get a failure to load with a memory crash. I am sure there is a way around this. Any ideas. Thanks for any help.

Edit update: Paulsep, thanks for your answer but I may have already figured it out. I will let you know what I did if it works.

message edited by Navyretire


See More: Help with Oricals Virtual Box and installing an Upgrade OS.

Report •

#1
May 15, 2016 at 13:26:28
✔ Best Answer
You might try to install Windows 7 Upgrade without product key.
When installation has finished, install all the available security updates.

When done, reboot Windows 7 installed in VM.
Run regedit and find the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE
In the right pane, you'll find an entry named MediaBootInstall.
Change the value von 1 to 0.
Close regedit.
Run command prompt as Administrator.
Type in:
slmgr /rearm

Reboot Windows 7 again.
After reboot, you should be able to activate Windows 7 in the normal way.


Report •
Related Solutions


Ask Question