Solved cannot connect to my TP extender TL- WA860RE

August 3, 2017 at 03:35:31
Specs: Windows 10
Having a TP-extender TL-WA860RE connected to my router from Virgin and working, my laptop (W10) cannot find the TL extender.
The TL extender is working as both lights green constant burning. Set-up TP has been done and connected to the router.
But my laptop still don't find it even I have all hotspot etc activated. Anything I did wrong?
thx, Peter

See More: cannot connect to my TP extender TL- WA860RE

Reply ↓  Report •

#1
August 4, 2017 at 02:08:00
✔ Best Answer
Range extenders can be a pain to get working and most of them are just not worth buying as even when they do work they are notoriously unreliable.

I solved my distance problem by changing my wireless router-- I spent nearly £200 on a top brand Billion wall-mounted router/modem and now I don't need a range extender.

I suggest you do the same.

A high-quality laptop (mine's a top-of the-range Toshiba) also helps with the WiFi range. My Toshiba gets a full signal (5 bars) 40 feet away from my router, whereas my wife's cheap Packard Bell only manages 2 bars at the same distance and won't connect.

So I gave my wife my Toshiba laptop, now she's happy.

I have a desktop PC with wired connection so I don't miss my laptop anyway.

So there you have it - - dump the range extender, buy a more expensive WiFi router (Billion recommended), and then a more expensive laptop if necessary.

Sometimes you have to spend serious money on quality gear to get effective and lasting results.

Good Luck.

message edited by phil22


Reply ↓  Report •
Related Solutions


Ask Question