PHPMail funcion working intranet not internet

Dell Poweredge r210 ii server- intel xeo...
September 25, 2012 at 06:28:37
Specs: Windows Web Server 2008 r2, Xeon 3.3 GHz 8GB ram
OK so as the title suggests, I'm having big time issues with my php

I am running php 5.2.17
php.ini configured for smtp=mail.mysmtp.com
port as well
mail from as well

now, I'm hosting under IIS7 Wordpress websites, and if I set them to mail just to me the reports of the usage of the website, it works, same for contact forms or anything else.

If I set it to send it out on the WWW for example me@gmail.com it gives either a error on the page when I set it to send, or it just doesen't send.

Can anyone help me with my problem? Would really apreciate it, also I can offer 3 months 10gb hosting with unlimited bandwidth and the possibility to extend it later.

p.s. no error under php_log.txt


See More: PHPMail funcion working intranet not internet

Report •


#1
October 5, 2012 at 09:54:20
Turn on debug logging for PHPMailer and post back the error message.

Tony


Report •

#2
October 8, 2012 at 01:36:43
I'm trying to.. but I don't get any errors..

Report •

#3
October 8, 2012 at 17:22:23
Are you echoing it out?

Tony


Report •

Related Solutions

#4
October 9, 2012 at 00:19:11
Am, sorry I'm not that much of a pro.

I loaded a mail test .php into my webserver.

http://www.tag-computers.ro/testmai...

if I configure it for internet it says, failed to send mail.

if I configure it for intranet... it works.


Report •

#5
October 10, 2012 at 03:05:42
Your ISP may block port 25 - many do - other than to their own mail server.

"Can anyone help me with my problem? Would really apreciate it, also I can offer 3 months 10gb hosting with unlimited bandwidth and the possibility to extend it later."

Does this Spam have any connection to your problem? If I were you I'd remove it before the mods decide to delete your thread.


Report •

#6
October 10, 2012 at 04:25:38
I can't edit it. but I'm serious, I can offer as a prize for who can help me.

Port 25 is fine.

On another ip adress, same ISP I can send mails without a problem.

Only problem is that another server is on that line, and I don't want to use it because it's pretty old and slow..

Initially I configured my php to send mails through that server.. same thing, send intranet, but not internet...

@ mods -> the 10gb is real, is not a spam, is a reward for who helps me solve the problem.


Report •


Ask Question