How to pass post-login command to server to load ./profile

November 1, 2019 at 10:41:01
Specs: Solaris
I must tell you first off that I am NOT a DBA.  My interaction with databases is from a user perspective, so please be lenient if I do not phrase something exactly right or if I am asking a really stupid question.  Here goes.I work with a third-party tool that allows me to issue a post login when it connects to the server.  I am trying source an environment variable on a Solaris server by issuing this command:./export/home/apphcmdev/.profile_stat_testingI do not believe that the command is being executed properly because at the beginning of the file we have a "touch /export/home/allhcmdev/sonia.txt" entry and the file is not being created.Now if I am logged on to the server, then the .profile_stat_testing file is loaded and the file is created.I know that Solaris and Unix are not the same, but if it helps at all, this identical approach works on Unix to load the .bash_profile via the post login command.Please no laughing.  I am at my wit's end.  I have tried Googling and have worked with the client's Solaris DBA and neither one of us know what the issue is.

See More: How to pass post-login command to server to load ./profile

Reply ↓  Report •

#1
November 1, 2019 at 11:37:05
./export/home/apphcmdev/.profile_stat_testing

That leading dot looks suspicious.


Reply ↓  Report •

#2
November 2, 2019 at 09:58:30
I have also tried without the leading dot, same result. Thank you for your response.

Reply ↓  Report •
Related Solutions


Ask Question