how to install a .bz2 file in solaris

January 5, 2012 at 02:18:57
Specs: Windows 7
I have downloaded the sourcenavigator-NG 4.3.tar.bz2 and when i tried to install it on my solaris "S10 U 8" OS.
i gave the following command:
tar -jxvf sourcenavigator-NG 4.3.tar.bz2

getting the following errors:
tar: j: unknown function modifier
usage: tar {c|r|t|u|x}[BDeEFhilmnoPqTvw@[0-7]][bfk][x...] [blocksize] [tarfile]
[size] [exclude-file...] {file | -I include-file | -c directory file}...

See More: how to install a .bz2 file in solaris

Report •

January 5, 2012 at 04:25:50
You may have to use --bzip2 instead of -j.

Report •

January 5, 2012 at 04:31:21
tar --bzip2 sourcenavigator-NG 4.3.tar.bz2

if i give this command it's throwing invalid block size error

Report •

January 5, 2012 at 04:39:23
Try this:
tar -xfv sourcenavigator-NG 4.3.tar.bz2 --bzip2

Report •

Related Solutions

January 5, 2012 at 04:51:10
Thanks Paul.
I tried that and getting an error like:
tar: directory checksum error.

I suppose it needs tar package manager...

let me try to figur it out.

Report •

January 5, 2012 at 05:07:00
You can also use this in the first place:
bzip2 -d sourcenavigator-NG 4.3.tar.bz2

and then untar it:
tar -xfv sourcenavigator-NG 4.3.tar

Should work for you.

Report •

Ask Question