Error: libstdc++.so.6 open failed.

October 22, 2010 at 15:01:05
Specs: Solaris 2.9 Ultrasparc, 32 bit
Hi, I am trying to install and run an application on my solaris machine(Solaris 2.9 Ultrasparc
). While installing it gives an error "ld.so.1: mancli: fatal: libstdc++.so.6: open failed: No such file or directory" but yet it got installed successfully. But when I ran the application(./mancli), I got error saying "ld.so.1: naviseccli: fatal: relocation error: file /opt/man/bin/manccli: symbol _ZTIN3CSP10EXCEPTIONS12CspExceptionE: referenced symbol not found".
I already installed all libstdc++.so libraries at /usr/lib and also set path to LD_LIBRARY_PATH env variable still why I get this error? Please help me in this situation.

See More: Error: libstdc++.so.6 open failed.

Report •

#1
October 22, 2010 at 19:13:14
Maybe, there is no libstdc++.so.6, but libstdc++.so.6.
Create a symbolic link named libstdc++.so.6 to libstdc++.so.5 (or what version is available on your system and give it a shot.

The original poster should always write the last response !!!
Let us know, if the problem is solved !!!


Report •

#2
October 25, 2010 at 08:35:38
Hi, I have done in that way adding symbolic links but no use. I read somewhere that the LD_LIBRARY_PATH is not good and it may break at times so don't set it. Is that true? Also should I install the specific library in some defined directory? Please advise.

Report •
Related Solutions


Ask Question