Can't login as root on solaris

March 18, 2010 at 08:49:26
Specs: Windows XP SP2, 1G
hi,

i can't seem to login as root anymore on solaris.i was trying to work with Korn shell but my default shell is Bourne. here is what i did.
1) Logged in as root, i created a user.
2) With the user i tried changing the shell of the user to Korn in the /etc/passwd file with
$ vi /etc/passwd but it was a read-only file owned by root.
3) I switched user to root and changed the permission of /etc/passwd to 777
# chmod 777 /etc/password
4) i switched back to the user and was able to edit the /etc/passwd of the shell used by the user.
SHELL=/sbin/sh To SHELL=/bin/ksh

The next day i tried logging in as the user and root and i was unable. i then logged in in safe mode and noticed the permission on /etc/passwd is lrwxrwxrwx and not -rwxrwxrwx. HELP!

Please note that i didn't install solaris on my system, i'm using VMware.


See More: Cant login as root on solaris

Report •

#1
March 18, 2010 at 13:04:29
You would need to boot to single user or from cd in order to change that back.

Playing to the angels
Les Paul (1915-2009)


Report •

#2
March 24, 2010 at 05:10:57
thank for responding,

Please can u elaborate.
thanks


Report •
Related Solutions


Ask Question