Click here for important information about Computing.net.

Solved Why won't Windows\temp\cpuz145\cpuz145_x64.sys delete?

January 22, 2021 at 18:41:33
Specs: Windows 10
I go to Safe Mode and Delete this folder that keeps showing up. Windows\temp\cpuz145 with its one file, cpuz145_x64.sys gone also.

As soon as I am back in regular mode, it is back. Defender doesn't say it is a problem, but two app installers AV with The application was unable to start correctly (0xc0000005) or The application was unable to start correctly (0xc000007b).

DISM (3 lines to check health and fix problems) and SFC scannow say all is well with my installation.

20H2 build with even more recent Updates here, Pro x64.

CPU-Z 1.94.9 x64 is installed.

THE REAL CPU-Z NEVER HAD A .SYS FILE!!!

Plus, I have never installed 1.45 on this Brand-New 3600XT/32GB/500GBx2SSD/5TBHDD Windows 10 Pro (Had Home, Upgraded to Pro via Microsoft.com, not a 3rd-party vendor) anyways.

Whatever this sys file is, it has BLOCKED my ability to gather Windows 10 Diagnostic Data, even after re-enabling it in gpedit.

Thanks & Stay Safe

message edited by RicardoMadGello


See More: Why wont Windows\temp\cpuz145\cpuz145_x64.sys delete?


#1
January 22, 2021 at 19:14:54
Here are the first 2 steps, more steps will be needed, after I see the results of these logs.

Step 1: Run AdwCleaner
https://www.softpedia.com/get/Antiv...
https://www.bleepingcomputer.com/do...
https://www.malwarebytes.com/adwcle...
https://toolslib.net/downloads/view...
Close all open programs and internet browsers.
Close all open programs and internet browsers.
Double click on AdwCleaner.exe to run the tool.
Click Scan Now
Click on Quarantine for all it finds.
Reboot.
Please Copy & Paste the contents of that logfile with your next reply.
https://i.imgur.com/qERgl4y.gi

Step 2: Run Malwarebytes Anti-Malware ( MBAM ) Use Threat Scan. Make sure Rootkit scan is on.
https://www.softpedia.com/get/Antiv...
https://www.freewarefiles.com/Malwa...
https://www.freewarefiles.com/scree...
https://www.malwarebytes.org/downlo...
Forum
https://www.malwarebytes.org/forums/
FAQ - Malwarebytes won't run or failed to resolve my issues
https://forums.malwarebytes.com/top...
Scanning, you will get something like this.
https://i.imgur.com/4NZ5Qw0.gif
https://i.imgur.com/rRfr1oD.gif
https://i.imgur.com/tShE6tQ.gif
https://i.imgur.com/iJZHDC0.gif
After a restart ( if required ) Copy & Paste the contents of the scan into your reply.
If too large, upload to a site of your choosing.
Follow these directions, until you get to Export.
https://support.malwarebytes.com/hc...


Reply ↓  Report •

#2
January 22, 2021 at 20:53:10
edit, Nope, they are not kidding! ;)

You Are Kidding, Right?

I ran the adware thingy and it is telling me to Quarantine my Advanced System Care Pro install PARTIALLY??

edit: Rather than suggest Official App Uninstall???

God Knows what would've been left behind after it got partially Quarantined by its actions.


Any other Ideas That Are Not Trying To Sell Windows FixIt Software?

message edited by RicardoMadGello


Reply ↓  Report •

#3
January 23, 2021 at 06:54:13
✔ Best Answer
cpuz145_x64.sys may very well be a legitimate file, did you do a search? Do you have Speccy installed? It appears to be part of that rather than CPUZ. Here's a thought - install Revo Uninstaller (if you don't already have it), then uninstall both Speccy & CPUZ making sure to use the Advanced setting so you can clear out any orphan files or registry settings. Also run CCleaner-Slim or CCleaner portable to clear out anything else that might be lurking about. Reboot afterwards. If you feel you still need CPUZ or Speccy, use the portable versions instead. Revo also has a portable version.

https://www.revouninstaller.com/pro...
https://www.ccleaner.com/ccleaner/b...
https://www.cpuid.com/softwares/cpu... (get the ZIP version)
https://m.majorgeeks.com/files/deta...

"it is telling me to Quarantine my Advanced System Care Pro"

Maybe you know something I don't know, but I wouldn't install it on my system.


Reply ↓  Report •

Related Solutions

#4
January 23, 2021 at 07:08:27
Mark Russinovich's SysInternals Process Monitor found this activity belongs to ioBit's Advanced SystemCare Pro v14's Performance Monitor.

I shall address this with ioBit now, thanks.

way too funny and sorry for my previous snarky.

Malwarebytes wants to Quarantine Advanced SystemCare, just like the adware thingy did, but neither pointed to cpuz145_x64.sys at all, so I moved on to finding a tool that monitors registry activity during boot.

This way I can have actual justification for uninstalling ASC, rather than just disabling its Performance Monitor.

Why ioBit has licensed this in such an old version?

Also uninstalled System Mechanic also.

Zenbeats, GOG Galaxy, and Opera still AV with 7B or 05 error code after all that, so this thread can go "Solved" and I now start a separate one for that. ;)

message edited by RicardoMadGello


Reply ↓  Report •

#5
January 23, 2021 at 07:12:54
cpuz145_x64.sys appears to be ioBit's licensing of CPUID/CPU-Z perfmon-related API.

edir: Confirmed Yes is True by CPUID/CPU-Z Support

It does not and never did come with CPU-Z app installs...

besides, my CPU-Z is 1.94.9, with 1.45 never ever being on here at all.

message edited by RicardoMadGello


Reply ↓  Report •

#6
January 23, 2021 at 07:18:30
Why are you using software like System Mechanic & Advanced System Care Pro in the 1st place?

Reply ↓  Report •

#7
January 23, 2021 at 07:28:24
10 After 40 years of development, I have made the assumption that these sorts of tools actually work these days, and except for this little jag these two actually perform quite well, in the areas that do work.

System Mechanic and Advanced SystemCare have bits and pieces that save me a lot of headache and time, actually.

As veteran Windows 95 2nd-tier Setup & Config Tech Support 2 years, followed by 11 years at Microsoft's Redmond Campus as contractor Hardware/Software Test Engineer I, II, & III, I normally do not use this kind of stuff ever.

GOTO 10

;)


Reply ↓  Report •

#8
January 23, 2021 at 08:52:37
Assuming your "resume" is true, that's even more reason for you NOT using these types of programs.
Wash, Rinse, Repeat.

BTW, I just noticed you joined the forum yesterday. Are you aware that it's shutting down & switching to ready-only mode on Feb 1st?

message edited by jam


Reply ↓  Report •

#9
January 23, 2021 at 09:19:39
resumé. you mean, yes it is real. :)

Feb 1 shut-down ouchers?

Got the Main Bug Issue up just in time then, eh?

Yes, for the most part, You Are Correct in saying these types of apps have Bad Rep for DECADES.

However, Developers want to keep their job, so continuing to put-out Bogus Crap doesn't facilitate that for very long.

So, as I turned 65 this year, Officially In My DOTAGE YEARS, got the "Senior Citizen" t-shirt and all.

I have decided to trust outfits that appear to provide actual working tools in this are.
They prevent me from spending hour-upon-hour going through RegEdit's lack of Bulk Find, Bulk Edit feature, deleting crap that lame uninstallers leave behind.

ioBit's Uninstaller app is Quite Tasty in this regard.
It even gets rid of Edge Beta, Dev, and Canary, which neither fully uninstall on their own.

just one example of RealWork activity these sorts of tools provide for us here in the 21st Century. ;)

Thanks Again!!! & Stay Safe

SysInternals Process Explorer & Process Monitor ROCK!!!
It just took my severly ADHD-addled brain a few days to finally remember their existence here on this. :)

edit2: My result from an incompleted round of AVSDK% Manual Registry Removal activity left it so bad Uninstall would not work, and ReInstall also failed to be able to access that given portion of the registry that I had wiped already. This was before I found out AVSDK5 comes with System Mechanic's AntiVirus portion, which doesn't have a "Do Not Install" feature, or Uninstall either. argh This is when I went to Safe Mode, Uninstall from there, hitting OK for each registry access error, until it finished and went back to normal mode, where I refused to reinstall it.

so, yes, in view of the fact these two apps CAN cause more problems than what the parts that do work help with. . .

and so, buh bye, System Mechanic "Ultimate" (Vanilla version is FINE) and Advanced SystemCare "Pro" (Vanilla version is FINE)!!! For both, the problems show with the Extra "Ultimate" & "Pro" apps, not included with their Vanilla versions.


beeg grin

message edited by RicardoMadGello


Reply ↓  Report •

Ask Question