When i download programs my Windows 8 doesn't open them

December 25, 2014 at 08:55:32
Specs: Windows 8
Hey! I recently got a new computer and now i'm downloading stuff for it but when i download fx Avg 2015 it doesn't open the setup. I can see it in my download folder an i keep clicking it but it won't open. I'm having this issue on other programs too.

I run a 64 bit windows 8 OS

See More: When i download programs my Windows 8 doesnt open them

Report •

December 25, 2014 at 13:35:00
As you are running 64bit OS, perhaps the versions of the apps etc. you're downloading are not designed for it: although many these days are both 32 and 64 bit?

Also are you logged in as Admin; as if not that may also be a reason. Usually (by default I think) many utilities and many apps require Admin privileges for installation?

Report •

December 25, 2014 at 14:27:45
Do your Updates & use Windows Defender & Windows firewall, I use them on all comps I work on.

Report •

December 26, 2014 at 07:28:40
I tried to run them as admin, when i did it asked me if i would allow the program to make any changes and then i clicked yes but then it acted like nothing had happened...

Side info: It doesen't work on any programs i download. It's .exe files and the first few programs i downloaded semms to be working fine. They're Iobit security programs and maybe thay have something to do with it?

Report •

Related Solutions

December 26, 2014 at 09:37:09
A quick look at iobit shows it to be package of PC utilities to "speed up, security items, clean out, and other stuff..."

Do you really need it? Frequently such packages seem to produce assorted problems of their own, and then "usually"/often require you to purchase more stuff to resolve them

If the programmes that won't install etc. are all related to iobit, then I suggest you get rid of iobit completely. Thee are other free stand alone utilities, frequently recommended here at CN, and all found to be trouble free.

Report •

December 26, 2014 at 19:03:00
Do a system restore back a while.
Do a Windows Update manually.
Try downloading AVG again, or better, download the free version of Avast (not the trial version) and uncheck the trial option during the install.
You do not need any of those other help programs. Installing Malwarebytes as a back up scanner to use about once a month and when you suspect you might have a problem, is about all you need. Many recommend CCleaner here and though I do not use it, I feel that enough here use it regularly that it is a safe program to use for keeping things clean on a regular basis.
The more ads you see for a program that appears to help you do everything to make everything better, the less you should trust it. Most will go over your system and tell you about all kinds of problems you supposedly have and tell you that you have to purchase their premium version to remove all of these fake problems and keep it running well. The lowest of the low actually install a form of malware that will gradually slow things down further if you try to ignore their warning and not purchase it.

You have to be a little bit crazy to keep you from going insane.

Report •

December 27, 2014 at 02:49:21
Where are you downloading AVG from? If the manufacturer then have you contacted them for support - that's what you pay for. If a pirated copy then you probably have now got all sorts of malware on the computer. The same goes for other programs - are you downloading them from legal sources?

Edit: Just read your further posts. Downloads used to work but when you clicked on one it appeared to do nothing. And then further downloads don't work. I'm guessing that you downloaded a malware infected program from a pirate site. It may have appeared to do nothing but, in reality, it did plenty.

message edited by ijack

Report •

December 31, 2014 at 05:58:53
I figured out how to get rid of the issue. I used Advanced system care, got the pro version and went to toolbox, windows fix and figured out that it might be a windows problem. Then i clicked the "fix windows" and there was an option to enable exe. files. Somehow it was disabled?

message edited by Henrik899

Report •

Ask Question