Virus disabled network communication

August 17, 2009 at 11:21:36
Specs: Windows XP 32 bit, 1 GB
I have a virus. Thus far, I have ran anti-malwarebytes, combofix, and avira.

It seems the virus is gone, but when I try to print or connect to a mapped drive it says the format is invalid.

The print will not communicate to the printer. It is connected via tcp/ip. I have the correct ip address and driver.

Everything was working correctly before the virus.

The virus seems to have disabled communication to the network. Yet, I can get internet access after running combofix.

See More: Virus disabled network communication

Report •

August 17, 2009 at 20:30:20

I uninstalled client microsoft for networks, uninstalled file and printer sharing. Rebooted. Then Installed again.

I am an it professional. Any response would be greatly appreciated.

Report •

August 23, 2009 at 10:36:55
Hi. I can't help you, but I seem to be in the same boat. I'm running Windows XP Home. The flakiness started happening to me around 8/19/09, with spotty Internet connectivity. By the evening of 8/21/09, my home computer stopped being able to access the Internet. Some troubleshooting showed the following:
1. Attempts to connect to the Internet all fail.
2. My high-speed Internet connection is gone from the network configurations.
3. When I attempt to use the network setup wizard, it completes the process, but then the new connection doesn't show up in the network window.
4. My network card is installed and says it's working properly.
It's as if something is hiding the network.
5. The network connection icon in the systray is gone.
6. Symantec Antivirus is installed and last recorded updated antivirus definitions some time in the afternoon on Friday, 8/21/09.
7. Attempts to use System Restore to restore the system to an earlier configuration all fail. System Restore tells me simply that it can't restore to the prior setting, but offers no help on why. Very strange.

So, it's like I have a virus, but I don't know what virus it might be or how to resolve it.

I'm an IT professional, too.

Any assistance would be appreciated. If this sounds like a virus, please direct me to information about it.

Symantec's web site seems to no longer be geared toward helping customers find information about viruses, but instead is all geared around customers paying them extra money for help.


Report •

August 26, 2009 at 08:32:59
Well, this forum turned out to not be at all useful to me, but in the event someone else stumbles across my post, I figured I would follow up and let you know the solution to my problem, which I figured out thanks to a colleague at work.

It turned out the built-in network card in my PC had failed. Very strange because in Device Manager, it claimed the device was working properly. I updated the NIC card driver, and that had no effect. I download antivirus defs and anti-spyware software from another PC, burned them to a CD and installed them on the other machine that wasn't working. I ran Microsoft's anti-malware tool, Norton AV and other tools; all of them turned up no viruses or malware.

I pulled a network card from another desktop, installed it in the ailing machine, and when I started it up, the PC recognized the network card, without my having to install any software. I set up a new network connection using the network card, and unlike past attempts to configure a network connection (see point #3 in post above), this time when it completed, Windows said it needed to restart the computer. When I restarted, it just started using the new connection, and I have access to the Internet again.

So, this turned out to be a hardware failure. The thing that made me think this might have been a problem with the network card was that I went to Start->All Programs->Accessories->System Tools->System Information. From that app, I went to the Tools menu and selected Net Diagnostics. I then told it "Scan your system." Before I put the replacement NIC card in, it showed no information for the Network Adapter, which I thought was odd. When I put the new NIC in, it behaved a lot differently, showing me the NIC card info under Network Adapter, and running more tests having to do with Internet connectivity.

If you run into something like this, try going through these steps.

I was SURE this was a virus. It didn't help that Device Manager insisted the non-functioning network card was enabled and working properly. That bogus error sent me on a scramble looking for apparently non-existent viruses. Very annoying. It's also disturbing that System Restore failed to work. I guess that's an unrelated issue.

Hope this helps.


Report •

Related Solutions

September 23, 2009 at 03:31:04
I have the similar problem. When I start up my pc, an error message shown " WiMax module failed to initialize", then another error message "run time error - Failure condition - Network interface object (null)", I thought that was my network adapter giving problem and i went to device manager to look into it, when pull down the network adapter, all the drivers shown exclamation marks, I right click on one of the driver and to the properties, the device status shown "Windows cannot load the driver for this hardware, The driver may be corrupted or missing". I reinstalled the driver but it could not help. I call up to the IBM service center and the technical officer told me it could be virus infected, the technical officer advised me to use spybot to scan my pc, due to i could not hook online, i use another pc to download the software and tried to install to my infected pc, but i failed to do so because to install the sogtware I need to online. so, the next step i done was took out the infcted pc hard drive and hook onto he other pc and done the scanning with AVG, no virus found. My infrared device also corrupted as well.

please help!

Report •

October 27, 2009 at 21:25:18
i have had this same issue on several machines on my network, what i have found that works is running the windows recovery from the disk...

Report •

October 27, 2009 at 21:31:23
reinstalling drivers won't work, it seems what ever this is that is causing it is blocking serveral services from starting. if you look at you services you will see that network connections has been set to manual. when you try to start the service it bombs out on you saying it cannot start and the service did not respond to the start or control request in a timely fashion. it also disables any remote access services from being restarted... i havent' yet found out what this is but i have seen it at least 6 times now. the quickest fix/ only fix i have found thus far is to repair from xp disk.

Report •

Ask Question