Missing XP themed32.dll file ruined my laptop

Microsoft Windows xp professional w/serv...
June 19, 2010 at 08:02:29
Specs: Windows XP SP3, 1 GB/1024 MB
Yesterday I was attempting to rid my laptop of the google redirect virus which is going round. I've been trying to get rid of it for a while but nothing was working. Another problem was that whenever i tried to run Firefox, I would get the error message saying Windows cannot find C:\Program files\...\firefox.exe. I reinstalled it several times but with no luck. I tried scanning my computer using Mbam, SAS, and my antivirus software, Bitdefender. Several viruses/trojans/spyware were deleted, including the firefox error. But the feckin google redirect problem is still there!
After rebooting after the final scan, i get several error messages saying "This application has failed to start because themed32.dll was not found. Re-installing the application may fix this problem.". This message would be in reference to several different processes, saying "Unable to locate component", with the message itself is the same. As a result, my desktop and start menu/bar do not appear, just my wallpaper. Even when I try to access the Task Menu using Ctrl, Alt, Delete, I get the error message(the message referring to taskmgr.exe in this case). Task manager runs eventually but again when I try to run any program, i get the error message, normally several times, before it runs.
I've tried looking online for how to reinstall themed32.dll but can't find a website where i can get it from. My guess is that either I still have a virus which is causing this error, or that the dll file was in fact changed somehow when the virus scans where performed.

That was a bit of a effort so thanks for reading. Any help/suggestions on how to get the themed32.dll back would be really appreciated.

edited by moderator: HJT log deleted


See More: Missing XP themed32.dll file ruined my laptop

Report •

#1
June 19, 2010 at 08:35:39
Do you have a Windows XP CD available?..

Helpful tips before getting started: http://www.computing.net/howtos/sho...


Report •

#2
June 19, 2010 at 10:14:11
No, unfortunately my laptop is fairly old so i don't have the
original CDs!

Report •

#3
June 19, 2010 at 18:17:17
You could try BartPE if you have a blank CD available: http://www.nu2.nu/pebuilder/

Also, did a search, and I could not find a themed32.dll but, I did manage to find a themeui.dll found here: http://www.dlldump.com/download-dll...

I don't know if this would fix your problem, but it's worth a shot.

Helpful tips before getting started: http://www.computing.net/howtos/sho...


Report •

Related Solutions

#4
June 26, 2010 at 07:00:52
try this, it murdered my comp. for a week.
task manager, new task, browse, windows, system32, all files, look for uxthemed.dll.
Now I found 3, one the original one numbered (2) and one with many digits and uxthemed.dll. I copied the two non original to a flash drive (just incase) and then delted them from comp. Rebooted and fine, desktop back and total scans and so far all ok.

Hope this helps.


Report •

Ask Question