Malware turned off Avast can't access web!

October 4, 2010 at 16:42:20
Specs: Windows 32Vista, 4gb
My PC cant access the web in safe or normal mode and Avast has been disabled, and cant be turned back on. I press fix now or start program but avast stays unsecured. I can, however, run scans with Avast, but it has found nothing!

Malwarebytes forund a few trojan.agent and trojan.fakeagent (or something similar)
Now MBAM doesnt find anything anymore... where is this thing hidding?
My pc was shutting itself down as well.
Please help if you can, I am so at a loss and cant lose all my schoolwork on it.
Ill be watching this thread so I can do whatever you recommend quickly.
Thanks in advance for your time.

vista 32


See More: Malware turned off Avast cant access web!

Report •

#1
October 4, 2010 at 17:02:25
1st of all open IE and click on tools/internet options/connections/Lan Settings and uncheck use proxy server. Try opening your homepage, if you are online, continue below

Now go into msconfig and uncheck ALL startup items.
Download rkill.exe and run it to shut down the malware process;
http://www.technibble.com/rkill-rep...
1- download tdsskiller and run it
http://support.kaspersky.com/viruse...
2- now open malwarebytes and do a full scan
3- Trojan Remover
http://www.simplysup.com/tremover/d...
After running those let us know if you still have some redirects

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

#2
October 4, 2010 at 17:30:17
Proxy was already unchecked.
Rkill or trojan remover didnt find anything, but the kapersky program found:
rootkit.win32.tdss.tdl3
(Malwarebytes didnt find anything)
I hit next and said cure and now it wants to reboot?
Should I go ahead?

BTW thank you so much for the assistance ;)


Report •

#3
October 4, 2010 at 19:26:07
actually, is there an option to delete instead of cure? Either that or quarantine the file, then run a bootscan with avast and delete it when found.

Some HELP in posting on Computing.net plus free progs and instructions Cheers


Report •

Related Solutions

#4
October 4, 2010 at 19:31:43
I didnt see a delete.
But after I was done, no online scanner could find anything and the tdsskiller came back empty this time.
So I am hoping i am in the clear.
What do you think?
(I am running avast now but it never found anything to begin woth so i dont have much faith in it right now)

-G


Report •

#5
October 4, 2010 at 19:50:38

Report •

#6
October 4, 2010 at 20:17:42
The boot scan has been going, but its only at 5%, so I am going to let it sit overnight.
Lets say it finds nothing...
Should I be clean at that point, hypothetically?


Report •

#7
October 5, 2010 at 04:42:58

Report •

Ask Question