I cannot access registry, tskm, and gpedit

Medionnb / Wid2010
May 3, 2009 at 23:23:43
Specs: Microsoft Windows XP Professional, 3.059 GHz / 1278 MB
I have a virus and trojan that for some reason keeps on coming back after I delete them, they won't let me into regedit or tskm or gpedit. I have try many programs including trojanhunter, mcafee, ad-aware, and spybot S and D. This thing automatically infects executable files and html. Mcafee detects and repairs the following trojan: w32/vivrt!htm.
The problem is that after it cleans once I restart it automatically executes the restrictions.
I have a hijackthis log upon request.

I have work on this thing all day. I would really appreciate anyone's kind help.
Thank You for your time

See More: I cannot access registry, tskm, and gpedit

Report •

May 4, 2009 at 07:04:23
Try to scan with Malwarebytes' Anti-Malware

or Scan DR-WEB scaner

Report •

May 4, 2009 at 08:59:34
stalinduke, Go to the link below, click on "Win XP Utilities" (left side), then click on "Create Emergency Copies of Critical XP System Utilities" then download the "xp_emegencyutil.exe" file. Instructions are on the page.

It creates usable copies of REGEDIT, MSCONFIG and Task Manager and may be of some help to you.



Report •

May 4, 2009 at 09:38:39
Hi maksimog
I ran the malware anti-malware, it did find
trojan vundu and it clean it but I still have the
problem. I could not get to the other website
because this thing has change my Internet
settings and I can't access that page. I tried
google to download from other host but no
such luck. Do you have any other
suggestions to get my registry and
taskmanager back?

Report •

Related Solutions

May 4, 2009 at 09:49:32
stalinduke, Try this for the Task Manager problem.

Click Start, Run and type this command exactly as given below: (better - Copy and paste)

REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableTaskMgr /t REG_DWORD /d 0 /f


For regedit try this:

Click Start, Run and copy & paste or type this command:

REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0 /f


Check out the links first prior to doing anything.


Report •

May 4, 2009 at 10:37:00
Thank you for your input Tefenuf;

This thing won't let me run the reg add because as soon as I run the fixes it closes them. I have tried your suggestions even the Doug Knox one. But this thing still doesn't let me into the registry or task manager or gpedit. Do you have anymore suggestions? Would you like to look into the hijackthis log?

Report •

May 5, 2009 at 21:39:55
I was unable to solve this issue with anti-malware programs
so I had to take drastic measures. I reformatted and have
started from scratch but I did get my important files. Thank

Report •

Ask Question