How to get rid of vsnpp106.exe in Vista

Custom / CUSTOM
July 8, 2010 at 10:18:17
Specs: Vista, Athlon
After re-installing Vista AVG free edition was
installed. To keep drivers up to date a program
called "DriverStore" was downloaded and
installed , AVG did not recognize any virus. A
second antivirus program "Immunet" was found
that worked somewhat different, and
"Immunet" found six infected files, three called
"vsnpp.exe" and three called vsnpp.dll and
quaranteed them.

Using the search program "Everything" I found
the three exe and the three dll files. Tried to
delete the six files, which were located in two
different maps, both called DriverStore, one
with a capital begin letter and one with a small
begin letter. I tried to delete all six files, but
only succeeded with four. I am left with two
both in the subdirectory:


There is no mention of the DriverStore program
in Control Panel\Programs and Features.

Looking in the internet I found "get rid of
vsnpp.exe as quick as you can", but trying to
delete these gave the error that I needed
permission to do so.
An advice to use "FileAssassin" of
Malwarebytes, but this was also not able to
remove the threat.
I used the Hunter mode in Revouninstall – not

Sorry the entry is so long. But who has a
solution ?

See More: How to get rid of vsnpp106.exe in Vista

July 8, 2010 at 12:26:17
Try booting off of a Windows Systems Disk the goto the recovery console. Browse to the directory that has the files and delete them.

Reboot your computer and see fi the files come back. If they do then you have a root kit. They are very hard to remove because they embed them selves in systems files. If ths is the case check this out...

Report •

July 9, 2010 at 07:37:15
Using the recovery console I managed to delete the infested
exe and dll files.

Then again I tried to see if I could get rid of the DriverStore
directory in System 32, but no go. To remove them using the
DOS commands I gave up because in the DriverStore sub-
directory there are 869 folders !

While in Vista tried to use the DOS cmd:
del c:\windows\system32\ driverstore /F /Q
but the DriveStore directory remained untouched.

Any suggestion how to reclaim the 1.26 GB on the disk ?

Report •

July 9, 2010 at 08:27:20
check the attributes on the Drivestore directory. It may be set to read only. If so, then either use the ATTRIB -RH command line command or do it through Windows.

That being said, Drivestore is a normal directory used by Windows. You may not want to delete it. Just empty the contents of the temp folder.

Report •
Related Solutions

Ask Question