Solved how to delete, PSW.AGENT.ARMV

March 16, 2012 at 00:42:10
Specs: Windows XP
Avg, keeps finding this trojan when I run a scan, and it cant heal it. My computer takes ages to fully load a page on the net. I have tried Malewarebytes, but it doesn't even detect it. Using XP... help !!

See More: how to delete, PSW.AGENT.ARMV

Report •


#1
March 16, 2012 at 06:57:56
✔ Best Answer
First, I would suggest switching to safe mode with networking, and then updating and rescanning with avg. Also I would redownload malwarebytes and reupdate and scan again. (since you already have these on the computer)

secondly, you could try returning to a previous restore point. The trick is to go back before the infection.

you could always do a hijack this scan and message it my way, ussually they dont like them posted here, but its a nice overall picture.

mike


Report •

#2
March 16, 2012 at 15:55:47
mikelinus

HJT logs are OK on here if they have been requested by any helper, such as yourself.

Having said that, most viruses have learned to hide themselves from HJT these days.

Always pop back and let us know the outcome - thanks


Report •

#3
March 17, 2012 at 04:56:26
I don't disagree, however with xp a lot of symptoms can appear on the hjt log that can lead towards a clue. Normally I would think that if AVG could detect that its reasonable that it should remove it, however sometimes AVG shows a false positive, or a reminent that doesn't matter. I suspect that the origional detect shows the malware that let something else in.

mike


Report •

Related Solutions

#4
March 17, 2012 at 08:37:46
Yep, any clues can only be a good thing.

Always pop back and let us know the outcome - thanks


Report •

#5
March 31, 2012 at 17:29:13
Sorry it has taken me so long to reply. It has taken me 10 days to get my computer running bug free.

Thanks for your help mikelinus & Derek, I tried the things you suggested and finally got rid of all trojans.

I ended up doing a complete scan 6 times, using 4 different anti virus programs, and found even more malware, which was cleaned. Then I completely removed all except Malwarebytes, and ran a final scan in safe mode, that fixed everything.

Now I use Malwarebytes & Comodo AV to protect my system, because Avg & the others use to much ram.

Thanks again for your help.


Report •

#6
April 1, 2012 at 05:18:40
Glad to hear you've sorted it out and thanks for popping back to let us know.

Always pop back and let us know the outcome - thanks


Report •


Ask Question