GOOGLE.COM redirected to SOFT.SG and NOT FOUND when search

December 20, 2011 at 07:12:27
Specs: Windows 7

I really needs help. Please help me asap. I'm now very very frustrated with my laptop T_T

- When I try to access, it automatically redirects me to this irritating website: "SOFT.SG" .However, when I access or other websites with this format "", it works find. I can use Gmail and other Search Engine normally. I'm only facing problem with "GOOGLE.COM" .

- When I use the google search toolbar, it shows a web page on Firefox that says:
"Not Found

The requested URL /search was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ Server at Port 80"

- I have tried Google Chrome, Firefox and IE9 and I'm facing the same problem

- I have tried using Malwarebytes' Anti-Malware, Hitman Pro 3.5, CCleaner, kk.exe, Rkill, TDsskiller to find spyware and malware but they all do not work.

- My host file is normal.

Really really needs help.

Thank you all!

See More: GOOGLE.COM redirected to SOFT.SG and NOT FOUND when search

Report •

December 30, 2011 at 08:47:40
I couldn't help but notice in that error message it is referencing port 80, that is a classic port used by hijacker viruses.

Go to and download Spybot - Search and Destroy. I know you said you tried all those programs, but this is the best one.

Also, go into your network connections and go into the properties of the active connection, select Internet Protocol v4 and click Properties below that.. all the fields in that box you see should be empty.

Did this help?

Report •

December 31, 2011 at 18:30:33
Spybot is quite OLD hat anymore.
You can run these 3 in the EXACT order as I suspect you may have an unwanted rootkit installed.
1- rkill.exe (stops the malware process)
2- TDSS killer (removes unwanted rootkit if found)
3- Malwarebytes (removes the remaining problem
Run a full scan and delete all it finds.
DON'T reboot untill after the malwarebytes scan.

You said you tried these, but try them in safe mode with networking.
Also give Trojan Remover a finds things others miss.

Some HELP in posting on plus free progs and instructions 7 Medals

Report •
Related Solutions

Ask Question