Firefox doesn't connect to the Internet, but IE does

April 27, 2013 at 19:37:18
Specs: Windows 64
I use Windows 7, 64 bit. Recently I uninstalled an older version of System Mechanic Professional using Revo uninstaller. The result was that Firefox and Thunerbird, both of which I was using daily, stopped connecting to the Internet, although Internet Explorer does connet. Many of my favorite programs, installed using Firefox, are now unable to update.
I checked to see that Firefox connection was allowed by my antivirus programs - Windows Firewall and Avast, and it was. I even turned all the AV programs off, with no improvement.
Enum gives me the following:

Enum Process
[color=#FF0000]Windows Firewall is on[/color]
[color=#FF0000]firewall process from Vipre Online Security detected[/color]
[color=#FF9900]antispy process from aSquared/Emsi Software GmbH detected[/color]
1 processes from GFI Software detected

I have never used Vipre, aSquared, or any GFU software.

Any suggestions as to what I should try next?

See More: Firefox doesnt connect to the Internet, but IE does

Report •

April 28, 2013 at 00:59:08
Try re-installing Firefox as that may re-configure it correctly.

The references to Vipre and aSquared is puzzling if you've never installed them. I suggest you use an up-to-date trial version of Revo Uninstaller to get rid of them, or it may be that you've installed some software with a different name and it uses those two components under licence.

Report •

April 28, 2013 at 11:17:10
Thanks. I already tried reinstalling the latest version of Firefox, downloading it via IE. It seemed to instal just fine, but still wouldn't connect. I downloaded an up-to-date Revo Uninstaller and tried that, and also the trial version of Revo Unistaller Pro, and tried the Hunter mode, but still no joy. I also tried reinstalling System Mechanic Professiona, but it couldn't link up to the Internet! I also went into the Control Panel and made sure that the default connection had been changed to IE, but that didn't let me update my anti-virus programs!

I didn't mention before that System Restore isn't working. I had been regularly saving restore points, but didn't test them. When I needed them, I just got error messages!

I guess that I'm going to have to delve into the registry. I'm a bit nervous about it, having never done it before.

Report •
Related Solutions

Ask Question