computer has a virus that wont let me access win7 defender

June 14, 2013 at 17:07:48
Specs: Windows 7
I cant access win7 defender. It says I don't have permission. The icon for it in the control panel is now just a folder. It also wont let me download any kind of virus or malware protection. It deletes everything as a virus. Also their are no restore points from before today.

See More: computer has a virus that wont let me access win7 defender

Report •


#1
June 14, 2013 at 18:40:53
Download these 3 progs to a usb drive on another computer. Then install them and run them in EXACTLY the order listed and do NOT reboot until after the last scan
1- rkill
http://www.bleepingcomputer.com/dow...
2-tdss killer
http://www.bleepingcomputer.com/dow...
3- malwarebytes anti-rootkit
http://www.malwarebytes.org/product...

Some HELP in posting on Computing.net plus free progs and instructions 7 Golds


Report •

#2
June 14, 2013 at 18:45:26
Thanks for your reply, ill give it a shot.

Report •

#3
June 17, 2013 at 14:28:50
I cant seem to get rkill to work or malwarebytes. Rkill just says its a registration & Malware says it doesn't have a correct path. I don't know what to do.

Report •

Related Solutions

#4
June 17, 2013 at 15:13:22
Probably the virus preventing you from running them.

For MalwareBytes try changing the download (mbam etc) to one of these:

iexplore.exe
iexplore.com
iexplore.cmd

If you can get it installed then it still might not run (but there are then other tricks we can try). My hope is that if we can run MWB and get shot of a few nasties, you might then be able to run the sequence already given in response #1.

Always pop back and let us know the outcome - thanks


Report •

#5
June 17, 2013 at 15:19:52
Best thing to do is try running the EXACT order in safe mode...

Some HELP in posting on Computing.net plus free progs and instructions 7 Golds


Report •

#6
June 17, 2013 at 15:36:06
Yep, #5 would be the best thing to try first (rather than #4). If that works then fine.

Always pop back and let us know the outcome - thanks


Report •

#7
June 17, 2013 at 15:41:40
I finally got them going. I wasn't able to access them in safe mode. Im running my last scan now so ill let you know how it goes. Ive been getting a lot of objects detected so it is working. Thanks again for your help.

Report •

#8
June 17, 2013 at 16:52:55
Nice work Derek, no best way, it's just a matter of finding a way that works, until we know what we are dealing with.

Report •

#9
June 17, 2013 at 16:55:01
VWKW
"Ive been getting a lot of objects detected so it is working"

Copy & Paste the contents of the logs into your reply, please.


Report •

#10
June 21, 2013 at 18:40:27
I couldn't get rid of it no matter what. So I ended up just wiping her clean & rebuilding. Thanks again for all of your help. I really appreciate it.

Report •

#11
June 21, 2013 at 18:43:41
Pity it had to come to that but glad to hear you are sorted and thx for letting us know.


Report •

Ask Question