Cannot use any search engine with any browser

November 17, 2011 at 16:43:20
Specs: Windows XP
I'm having an issue with connecting to search engines. Every other website I've tried to go to has worked perfectly fine, the only affected sites seem to be search engines. I've tried navigating to google, bing, and yahoo on IE, Fire Fox, and Opera, google and bing would try and load for around a minute or two before giving an error of cannot connect to remote server or server timed out, while yahoo would load, but when I tried to click the 'search' button I got the same long loading time and eventual server error as I did with google and bing.

I've been reading support pages from microsoft, firefox, and combing through threads about this issue for 2 days now with no results that corrected my problem. The only good thing that has come out of my hours of reading "solutions" and implementing them all to no avail is that I've learned HOW to explain my situation as clear and specific as possible. I'm going to try and break this up into 'topics' of details and information about my issue based off of all the information I've seen needed in other threads, so thank you in advance for your time, knowledge, and patience.

I. PC Details
II. Issue Details
III. 'Solutions' Implemented and Failed

I. PC Details
I am experiencing this issue on my PC at work. It is running XP Pro SP3 and connects to the internet via the in-house server that every computer in the building connects through, yet mine is the only PC with this issue.

II. Issue Details
A few days ago I tried to navigate to [], in Fire Fox, and it tried loading the page for about a minute or two before giving me an error message that said something to the effect of "could not connect to the remote server" or "server connection timed out." So I tried using the search box to the right of the address bar and had the same error. So I tried navigating to [] and had the same problem, the I navigated to [] and the page actually loaded, BUT when I typed something into the search box and hit search, I had the same problem as google and bing. So I tried opening google, bing, and yahoo using Opera instead of Fire Fox, exact same problem as Fire Fox, so I tried the same in IE and got the same thing. Every other website I've tried navigating to works perfectly fine on all browsers, the only sites that seem to have problems are search engines.

III. 'Solutions' Implemented and Failed
After reading all the 'solutions' to similar problems so far I've tried to implement them but the problem still remains.
Solutions that failed:
-Restart computer
-Run Malewarebytes
-Run AdAware
-Run Microsoft Security Essentials
-Restore PC to 2 weeks before the issue started
-Start>Run>CMD>ipconfig /flushdns
-No proxy's in firefox network settings
-No static DNS in connection TCP/IP Properties (connection set to auto IP and DNS info)
-Restart the router and modem
-Restart the entire server

The last 'solution' I tried was to edit the "hosts" file found in C:\WINDOWS\System32\drivers\etc. When I opened the 'etc' folder in windows explorer there was no "hosts" file there, even with hidden files and folders being shown, although there is a lmhosts.sam file that when opened in word pad was just 10 or so lines of a "sample hosts file" but and the beginning of every line was a "#". EVERY line in this lmhosts.sam file started with a "#".
So I tried opening a new wordpad file and typed " localhost" and tried saving it as "hosts" in C:\WINDOWS\System32\drivers\etc. It saved, so I restarted my PC and tried using a search engine, no results. so I went back to the 'etc' folder and noticed the file had saved as hosts.txt, even though I made sure to save the file as "hosts" with no ".txt" behind it and I saved it as "All Files" instead of ".txt File". So I tried renaming the hosts.txt file as "hosts" and when I did I got a error window saying there was already a file with that name. So I tried going to Start>Search then typing "hosts" and clicking search, no results.

I can open the "hosts" file by going to Start>Run and typing the hosts file's location, "C:\WINDOWS\System32\drivers\etc\hosts" and open it with word pad, but when it opens it has all the sample host file information with "#" starting every line with only 2 lines NOT starting with "#". Line 1: " localhost" Line 2: "::1 localhost".

I've tried deleting the second line and saving the file. it saves but after restart nothing is changed and if I open the file again it still has the second line. I've tried saving as hosts in the 'etc' folder (NO ".txt" and saved as "All Files") but it still saves it as hosts.txt and I still cannot change the file name to "hosts".

I've tried running HijackThis and when the program opens it pops up an error message saying it doesn't have write access to the hosts file and any changes it recommends to make to this file be done manually. I've tried deleting the second line with HijackThis but it doesn't remove it.

I think that covers all the important parts so we don't have to start with "Did you make sure the computer is plugged in?" or anything like that.

Thanks again, sorry if I left something out, sorry if it's too long, if you need any more info just let me know what it is and I'll get it for you.

See More: Cannot use any search engine with any browser

November 21, 2011 at 09:37:07
I have resolved the problem. I used Malewarebyte's FileAssassin to delete the hosts file that existed but I could not locate or make changes to then used HostsXpert to create a new MS hosts file, after that I restarted the computer, search engines still didn't work, so I opened CMD and typed "ipconfig /flushdns" hit enter, still nothing but after a system restart and about 10 minutes waiting time my search engines all started working again on every browser.

For anyone else experiencing this issue, it can be hard to find a solution since you can't get to any search engines. The following links should help is google's IP that will allow you to access google even when you cannot navigate to google by typing the URL in your address bar. I hope this helps, it got my system back up in working order even when all the other solutions to similar problems could not help.

Report •

November 22, 2011 at 05:13:42
Good for popping up back, the info might be usefull for other people too.

Thanks and kindly regards,

Happy is ONE who says I am an OttoMAN.

Report •

December 1, 2011 at 12:05:33
Problem still persists, it worked fine the first day but reverted back to not working a day or so later, hosts file is fine now but still no search engines.

Report •
Related Solutions

Ask Question