Solved Avast deleted data alongwith virus

Dell Studio 1550
July 31, 2011 at 13:14:02
Specs: Windows 7, Intel core 2 duo T6500 2.10 Ghz/ 4GB ram
My external HDD(500GB segate golfex) there was around 190GB of data (study material + photos + games + movies etc ) it had trojan horse in its folders i used Avast antivirus it scanned and deleted ALL DATA along with virus. i can see in properties that the disk space filled is around 190GB i.e the data is still there but i tried using Commmand prompt and other general methods to view and access data but all futile. I m in deeep trouble kindly help

contact me at ""

Thanks & regards


See More: Avast deleted data alongwith virus

July 31, 2011 at 14:05:25
✔ Best Answer

Need further information...

Due to the virus, did all the folders on the external HDD connected to the computer turn into .lnk files?

Check the folders out, post back.

In the meantime, open up Folder Options:
Click the Start button > Control Panel > Appearance and Personalization > Folder Options

Click on the 'View' tab

Go down the list and check: 'Show hidden files and folders'.

Next, uncheck: 'Hide protected system files'
Click: OK

Now go to your external drive and see if your folders are back.

If there, download Unhide.exe to your Desktop:

If the file does not download, copy/paste the following link >without brackets< in the address bar of your browser:

Right-click on unhide.exe and select: 'Run as Administrator '
Allow the program to run.

This program removes the hidden attribute from all the files on your hard drives.

Let us know how it goes.

Post back on the outcome, as we may still have more work to do.

Also, it is not a good idea to post your email address for everyone to see.

And, in any event, my guidance in this forum is posted so that others have access to the information and can use it to solve similar problems.

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 1, 2011 at 08:46:48
Hey thanks for the help, I unhided the icons and use command prompt etc already, just forgot to unmark the proteced files option in view part of folder option and just did it and i can see all files hidden but i am unable to unhide them the check is disabled how do i re- enable it.

Thanks for the reply though :)

Report •

August 1, 2011 at 09:12:40

See if this works:

Run regedit ('Start' 'R' simultaneously)

Go to the following key:


On the right side, find 'Hidden'

Under Data, what is the value for 'Hidden'?

If '0' (zero), right-click on Hidden and select Modify.
In 'Value Data' area, replace the value from 0 to 1.

Retired - Doin' Dis, Dat, and slapping malware.

Report •

Related Solutions

August 1, 2011 at 09:28:09
I accessed that but the value for "hidden" is already '1'
but the value for all other like 'HIdeIcons', 'IconsOnly' and 'SuperHidden' is '0' do i need to change them ??

Thanks for the reply


Report •

August 1, 2011 at 09:34:57
Just run attrib -s <drive letter>:\* /s /d from the CLI....

Report •

August 1, 2011 at 11:32:16

"...the value for all other like 'HIdeIcons', 'IconsOnly' and 'SuperHidden' is '0..."

I'm also runnign W7, and those are the values in the Registry key.

If you run the following command, does it help:

attrib -s -h [drive:]*.* /s /d

This should change the attribute on all directories and folders in the specified drive letter including subdirectories if all files and directories were hidden, and the hidden attribute was greyed out.

Note for anyone looking for a solution: Do not use this command on you C:\ drive! It will completely expose all system folders, and, in most cases, is not a good idea!

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 1, 2011 at 12:06:20
i ran "user/nayab> attrib -s l:\*/s/d " on command prompt but it said path not found

drive is l:

Report •

August 1, 2011 at 12:09:59
attrib -s -h L:*.* /s /d
it said invalid switch

Report •

August 1, 2011 at 12:17:36
Try post #5 from Squirl...

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 1, 2011 at 12:29:15
If no-go, check:

Is 'Checked Value' set to 1?

Have to go out for a while. Will check with you later...

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 1, 2011 at 12:45:24
the value is already set to '1'

i already tried Squirl's response but it didnt work :(

actually only the outermost folder is having this problem. so i replaced the outermost folder and there is no prblem with it.

if there is no other solution then shall do the same for all others manually :)

thanks Aaflac44 for all the help provided, and squirl too :):)

Report •

August 1, 2011 at 14:30:49
Was wondering...

Were you running an elevated command prompt?

Open the Start Menu.

In the Start Menu search box area type cmd, then right click on cmd (at top), and click on: 'Run as Administrator'

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 1, 2011 at 14:40:05
It's invalid because you didn't input a backslash:

attrib -s -h L:*.* /s /d
attrib -h L:\* /s

The -s will remove the "System" attribute, which is not really something you want to do (it exposes Desktop.ini etc).

Report •

August 1, 2011 at 14:48:41
Well, one of us is going to get it right...LOL

We both suggested: -s
But that can be reinstated later.

My bad!!! No slash \ aaargh!! Getting rather cross-eyed...

Retired - Doin' Dis, Dat, and slapping malware.

Report •

August 2, 2011 at 02:10:22
So we did....My apologies! :)

Report •

Ask Question