xcopy vs copy

April 7, 2009 at 10:13:36
Specs: Windows 2008
I am trying to use xcopy.exe to copy a file in Windows 2008 server but it continues to ask me whether the destination is a file or folder. I have tried the switch /i and every other switch.

I would like to use copy.exe, but I can't find it in system32. I will not be working directly from the command prompt, so I can't just type copy.

All I need to do is copy one file from one folder to another.

Also, if the option isn't included in windows and I would have to download it (i.e. robocopy), then it is not a viable option for me.

Hope someone can help. Thanks guys.

See More: xcopy vs copy

Report •

April 7, 2009 at 14:53:31
Copy is an internal command so it doesn't have an executable, copy is "inside" cmd.exe. Open up a cmd window(start>run>cmd) and type in "copy /?" to confirm this.

I know you say you cannot do it from the command line but this is just an example, copy will work from a script.

Report •

April 8, 2009 at 18:40:00
I believe that this message would come up as a result of haveing a directory with the same name as a file in the same folder. What happens when you tell it that it is a file? Have you tried temporarily renaming file/directory of the same destination name? Can you perform the copy in explorer? Are you able to copy the file to a different destination? The answer to any one or all of these questions could help alot.

John W. Borelli
IT Specialist

Report •

June 3, 2009 at 13:48:58
I recently ran into a similar problem in XP and got around it by using 'ECHO F|' to stuff an 'F' into the xcopy command, So instead of

xcopy c:\myfirstfile.txt c:\mysecondfile.txt

I use

echo F|xcopy c:\myfirstfile.txt c:\mysecondfile.txt

Something I remembered (dimly!) from my DOS days :-)


Report •

Related Solutions

Ask Question