Solved Vbscript - Creating IE 9 Object

January 25, 2020 at 03:43:12
Specs: Windows 7, 1.6 gb 4gb
Hi, looking for some help or information with a problem. I have an old laptop running Vista Home Premium and IE 9 as it has some programs on it that I like to use from time to time although I do NOT use it online. While using it an old vbscript caught my eye so I ran it out of interest. To my surprise I found that it no longer worked and produced an error message immediately at the line:
Set objExplorer = CreateObject("InternetExplorer.Application"). A quick check confirmed that every vbscript prog on the laptop with that line of code wouldn't run either. The error message stated that permission was denied and quoted error 800A0046. I have tried every possible solution I could find on the internet but to no avail. Things that I have tried in vain are:

Turning off virus checker
Turning off firewall
Ensuring that active x and scripts are permitted to run
Unable to get full admin rights over iexplore.exe and vbscript (options were all greyed out) until I had taken ownership. Made no difference
Checked that windows had a copy of scrrun.dll
Checked that scrrun.dll existed
Checked that registry entry for InProcServer32 existed - it did = C:\Windows\System32\Scrrun.dll
Tried to re-register dll in case it wasn't actually registered. It wouldn't let me - regsvr32 error said DIIInsdtall entry point couldn't be found so the dll is probably registered
Registry correctly showed the link to the dll so it knew where to find it ok
Made sure ie was the default browser in the vain hope that that might make a difference!
ie privacy level set at medium
No question of 32bit and 64 bit conflict as I only have 32 bit Vista system

I did notice that Admin rights on scrrun.dll are only "read and execute" and "read". The boxes are all grayed out and I can't make any changes even as Admin unless I "take over". I haven't done this yet as I feel I'm getting into uncharted waters and want to be cautious. The error message on trying to re-register scrrun.dll is concerning. I've had that sort of message before and it always seemed to be where an app had been updated and involved calling on a new procedure which was not available under the current system - an example would be a program which worked ok under windows 7 but after it had been updated for windows 10 no longer worked on Windows 7.

I am left wondering, though, if this is something that Microsoft has done as one of its steps in the demise of vbscript. Yet I couldn't find anything on line that tended to suggest that. If anyone can help I would be grateful. Apologies for the length of this epistle!

PS Just before posting this I have now managed to run regsvr32 "c:\windows\system32\scrrun.dll" and the dll has re-registered. It wouldn't do so when I used regsvr32 / i "c:\windows\system32\scrrun.dll". However, I'm still unable to create ie object.


See More: Vbscript - Creating IE 9 Object

Reply ↓  Report •

#1
January 25, 2020 at 22:59:56
✔ Best Answer
I'm using IE-11 on win-7 "ultimate" 32-bit sp-1. I had my line as:
"createobject(internetexplorer.application.1)"
for my vbs and it works. I removed the ".1" and it still works (performs the navigate
method and opens a page). Might be IE-9 is too outdated? Also, and this is new for me, got this f_ing popup "Do you want to open this file..." bulls---. Click "open" and it works. "CANCEL" and you get "access denied". Need to dodge the f_ing dia-box, but otherwise works over here:

set ie=createobject("InternetExplorer.Application.1")
ie.visible=true
ie.fullscreen=false
'this foll. just dodges dialogue boxes should they occur
ie.silent=true
if wscript.arguments.count=0 then
wscript.echo "URL is needed to navigate"
wscript.quit
end if

url=wscript.arguments(0)

ie.navigate wscript.arguments(0)

------------
on-line search to defeat this nuisance dialogue-box crap. other than that it works
PS: Tried it today running from a different subdir. and it didn't get the dialogue box. I was running it last night from my browser's cache, content.ie5, and that apparently incurred the protective wrath of Microsoft. But that's nothing to do with your issue, although when I hit the cancel, it does give me "Access Denied" error but not from vbs/cscript.

message edited by nbrane


Reply ↓  Report •

#2
January 26, 2020 at 02:41:59
Thank you, nbrane, for your comments. I also have no problem creating an object on another laptop running windows 7 with IE 9. I tried running sfc /scannow but it gave a clean bill of health and made no difference. However, this morning I realized that I hadn't tried to run the script in Safe Mode so tried that. You know what, it worked perfectly! Sadly, I am no further forward in identifying the problem. Disabling all the IE extensions made no difference - they were all Microsoft ones apart from 2. Looks like I'm stuck but at least I can use Safe Mode if I have to.

Reply ↓  Report •

#3
January 26, 2020 at 06:44:22
Just ran system through Tweaking.com and while it has caused other problems I've still got the unable to create object problem

Reply ↓  Report •

Related Solutions

#4
January 28, 2020 at 03:34:53
Did a reset of IE 9 which unfortunately took it back to a version before current one. I can't even re-install the current version as I get an error message saying later version is already installed! Still have the same problem unable to create object.

Reply ↓  Report •

Ask Question