Solved Unable to create Shared libarary in AIX 6.1 server

December 21, 2011 at 03:21:02
Specs: AIX 6.1
$ gcc -shared -Wl,-brtl,-soname,libFshxct.s0 -o probit.o
ld: 0706-005 Cannot find or open file: libFshxct.s0
ld:open(): A file or directory in the path name does not exist.
collect2: ld returned 255 exit status

We are migrating our Java/C code from HP-UX server to AIX 6.1 server.I am facing problem while creating shared library in AIX server.I first compiled all Java/C code and then tried to create shared library using above specified command in AIX server.

In HP server I used below command to create shared library.Same is not working in AIX.

ld -b -B immediate V_cfshxct_arg_with_zscore_match_bkp.o qnorm.o lgamma.o -o

can any one help me to find equivalent command for shared library creation on AIX server?

See More: Unable to create Shared libarary in AIX 6.1 server

Report •

December 22, 2011 at 22:56:27
Can any of the members help me on above? its urgent !!!!

Report •

December 22, 2011 at 23:38:47
AIX is not exactl a mainstream topic. Have you tried IBM support?

Report •

December 23, 2011 at 00:06:41
✔ Best Answer
Two further thoughts.

1. Have you read this article about using gcc on AIX?

2. Your error relates to the file libFshxct.sO. Shouldn't that be .so?

Report •

Related Solutions

December 23, 2011 at 01:44:35
Thanks for your response.I will post my query in relevent forum too.
Nice observation,you are right its should be .so not .sO.Though I am still getting some error.

collect2: cannot open as COFF file

Report •

December 23, 2011 at 03:39:36
I wonder if you actually need the -soname switch at all; the article from IBM didn't mention it when creating a shared library.

Report •

December 27, 2011 at 02:47:11
removing "-soname" doesn't make any difference.Still getting same error message

"collect2: cannot open as COFF file"

Report •

Ask Question