The Application cannot be started Contact the Application

April 25, 2012 at 11:13:36
Specs: Windows XP
This problem was a real pain to track down so I thought to post it.

The error message that end-users received was: “The Application cannot be started Contact the Application Vendor” (this would happen to about 15% of the people in our department when trying to install the app)

“There are a couple of issues we found with Click-Once apps where a .net file gets out of synch with the registry. The problem is resolved by deleting the UsrClass.dat file from the users C:\Documents and Settings\<ad-ent>\Local Settings\Application Data\Microsoft\Windows\ folder. …This solves the problem probably 90% of the time. “

MS notes on their site to delete the cache which did not work for us. The cache located at:
C:\Documents and Settings\SomeUserName\Local Settings\Apps

I created a batch file using the line of code below, which works as long as the file is not locked (in use).
del /Q /A:H "C:\Documents and Settings\"%USERNAME%"\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat"

See More: The Application cannot be started Contact the Application

Report •

April 26, 2012 at 00:57:15
What is the error in the event viewer? Also if you suspect it's the RTC you may want to check the voltage on your BIOS batteries, they only last about 3 to 4 years.

Report •

April 26, 2012 at 06:17:15
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Following errors were detected during this operation.
* [2/8/2012 2:49:29 PM] System.UnauthorizedAccessException
- Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
- Source: System.Deployment
- Stack trace:
at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore(UInt32 Flags, IntPtr hToken, Guid& riid)
at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore()
at System.Deployment.Application.ComponentStore..ctor(ComponentStoreType storeType, SubscriptionStore subStore)
at System.Deployment.Application.SubscriptionStore..ctor(String deployPath, String tempPath, ComponentStoreType storeType)
at System.Deployment.Application.SubscriptionStore.get_CurrentUser()
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

Report •

April 26, 2012 at 11:46:22
Looks like the user does not have permission to install the application. Have you logged in locally and tried to install the app?

See if any of this helps

Report •

Related Solutions

April 26, 2012 at 14:19:30
When i entered this post, i also entered in the answer... just to clarify. Why?, because it was a pain to find a fix!

Click once messages can be missleading; for example the detail (pasted above) notes: "UnauthorizedAccessException" and so you might think this is a permission issue... that would be wrong. For most of our end-users having problems installing the app, the fix was to delete this file: UsrClass.dat (as noted above). it's a registry or .Net framework corruption. Changing permissions was tried but did not correct the problem.

We can thank MS for giving us worthless error msgs. And when you want to find the fix you don't go to MS, you go to forms like this.

Report •

April 26, 2012 at 14:42:16
Sure does look like a permissions issue to me. Try to restore default admin permissions.

Report •

April 26, 2012 at 14:46:00
What is the software we are talking about anyway? What is your environment? Active Directory, workgroup? Was this a server side install of the app or installed locally?

Report •

April 26, 2012 at 15:16:10
Your funny, the problem was solved and posted from the very beggining. It's VB.Net using Click-Once, Click once has it's own set of rules. I'm not a server guy and somewhat new to programming in .Net.

The one outstanding issue of note is that you can have problems deleting this file: UsrClass.dat

Report •

Ask Question