net share accepted but doesn't share

Microsoft / Windows vista business sp...
September 22, 2010 at 06:08:44
Specs: Vista business SP2, Core2 6400 / 2gb
I'd like to make a batch command file to share a few dozen directories (with full privileges, just long enough for SyncToy to synchronize them) and then another batch file to unshare them. The NET SHARE command seems to be the way to go but although it seems to be accepted correctly ("sharenameABC was shared successfully.") the folders are inaccessible to the other machine on the network ("Windows cannot access \\computer\folder You do not have permission..."). I suspect I'm not getting the syntax or content of the NET SHARE command right. I've tried:

NET SHARE sharenameABC=C:\ABC /GRANT:Everyone,FULL

I'd be grateful if anyone has the answer (or other ways to accomplish the same goal). Thanks much!

See More: net share accepted but doesnt share

Report •

September 22, 2010 at 09:42:27
Hi rappleman,

So far I know you have to add a drive letter at the command too.


NET USE /? for more information.

Kind Regards,


Report •

September 22, 2010 at 15:37:59
I'd suggest running your command (which looks correct to me) then checking your folder shares under computer management (compmgmt.msc from the run dialog).

From here, check the share permissions and make sure they make sense and are created as expected.

What version of Windows is this under? If you create the share manually and test, does it work?

Also, as an aside - make sure the Guest account is enabled if you're using it for this purpose.

Report •

September 22, 2010 at 16:55:15
Make sure you're running the NET SHARE command from an elevated prompt, and not the "normal" Command Prompt.

Report •

Related Solutions

September 22, 2010 at 18:42:36
Solved! Thank you all!

Report •

Ask Question