Issue remotely installing Google Chrome with psexec.

May 2, 2012 at 11:26:12
Specs: Windows XP
I am currently having issues getting Google Chrome to remotely install with the following script:

for /F "usebackq delims==" %%I in ("TargetComputers.txt") do Call :begin %%I
goto :EOF

set comp=%1
:get info
robocopy \\<server>\Scripts\ExesToInstall \\%comp%\c$\1Temp /XF DNI_*.* /r:0 /w:0
psexec \\%comp% -i cmd.exe /c c:\1Temp\ChromeSetup.exe REM /SILENT

The file copying completes successfully and I am able to install it fine if I run it from the destination computer, but on the psexec call the command prompt shows up on the destination computer, followed by the following error in a Google Update Installer message box:

"Google Update installation failed with error 0x80070057."

Both the computer I'm running the script on and the computers I'm targeting are Windows XP SP3.

Any help would be greatly appreciated.

See More: Issue remotely installing Google Chrome with psexec.

Report •

May 2, 2012 at 12:11:44
0x80070057 = E_INVALIDARG
The installer is probably getting that error from Windows, so it just aborts and returns. I don't know exactly what's it doing that Windows doesn't like. There's a chance, a slim one, that Process Monitor running on the client will show you what's going on.

If I had to guess, I'd say it's trying to access the user's personal directories. Since psexec runs programs outside of the user environment, the conversation would go something like this:
Google Update Installer: Where's the user's Application Settings?
Windows: What user?

How To Ask Questions The Smart Way

Report •

May 2, 2012 at 13:03:25
Thanks for the idea. I downloaded and ran Process Monitor and then tried the script. I don't really know what I'm looking for, but I would assume the multitude of CreateFile operations with "NAME NOT FOUND" results might be the issue. It seems they are trying to create files inside C:\Documents and Settings\[user]\Local Settings\Temp\GUMB4.tmp. After those the only other "NAME NOT FOUND" is from a RegQueryValue of HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\GRE_Initialize\DisableMetaFiles.

I don't really know much about the workings of tmp files or registry values and, since it's almost closing time, I'll have to look more into this tomorrow.

On a related note, the script works flawlessly for installing Firefox, just not Chrome. I may just have to mark this up as an annoyance from Chrome's part.

Report •

May 2, 2012 at 13:11:37
Chrome installs program files to the user's settings directory. Firefox does not. That's probably the difference.

But if you're looking though Process Monitor, you should be looking for a return of INVALIDARG, because that is what Chrome's installer is choking on.

How To Ask Questions The Smart Way

Report •
Related Solutions

Ask Question