From TFSBuild, PsExec batch is not executed

November 30, 2011 at 04:06:24
Specs: Windows 7
PsExec batch file runs stand alone but when I invoke the batch file from within TFS 2010 Build template, it returns with error like

Access is denied.
Connecting to localhost...
Starting PsExec service on localhost...
Could not start PsExec service on localhost:
Connecting to localhost...

and does not do anything.

How to have that batch file executed from TFS Build definitions?
Any help is appreciated.

See More: From TFSBuild, PsExec batch is not executed

Report •

December 1, 2011 at 06:26:03
Access is denied.
I'm lucky enough to avoid Team Foundation Server 2010, however I suspect UAC is getting in the way. Try running TFS as an Administrator.

How To Ask Questions The Smart Way

Report •

December 1, 2011 at 23:57:48
I always run the cmd console and TFS IDE as administrator.

The issue is resolved to an extent.

I normally connect to my client machines via VPN. When I am connected in that, it generates a dynamic IP. To check that, I used all the computer references as LocalHost/MachineName/MachineName.DomainName/DynamicIP/IP that is listed as IPV4. When I ran the PsExec from TFS, all the references failed other than the IP that is listed as IPV4.

For now it is okay, but still not sure why other references failed.


Report •
Related Solutions

Ask Question