file rescue from a 15 years old com

March 6, 2009 at 04:32:25
Specs: DOS 3.3
I am supposed to get files out of an very old computer.
It is an IBM Personal System/2 Model 50. It runs with MS DOS 3.3.

The files I need to save are .lib-files (containing the whole meta information of a Library).

It is possible to copy them successfully to a 3 1/2 floppy disk, but when I put the floppy disk into a drive of a more modern computer, the system tells me "there is no disk in drive". I tried with different computers here. They all announce the same message.

I assume a problem with the DOS version. The floppy disks have been formatet under the old system DOS 3.3. The modern computers use much higher versions. Maybe this ist the point. . . .

However. ... I need somehow to copy the data to a modern PC.
Is there a solution?

I had also the idea to connect the hard drive as slave to a modern computer, but it seems the hard drive in this old IBM PC is fixed within the case, furthermore the connection to the the rest of the system is totally different in the old PC.

It is an 20 MB hard drive, IBM, Model: WD-325N

There are several more informations:
P/N 90X6806
Type 30
20 MB
MLC: A07282

I am glad for your help,

See More: file rescue from a 15 years old com

Report •

March 6, 2009 at 05:03:07
I use a USB to IDE adapter to connect old hard drives to my PC. I've used it on PCs running DOS all the way up to Vista. With the adapter you should be able to connect it into the old computer without removing the hard drive from the computer chassis. Any good computer shop or on-line retailer should stock the adaptors. Rgds,

Report •

March 6, 2009 at 06:12:05
the problem is, I can not take the hard disk out of the computer and it seems the connection to the rest of this computer is not an IDE. I can not describe what kind of connection or adapter would be needed.

Report •

March 6, 2009 at 06:37:46
In a case much like that you are facing I used the following

It is free and requires a serial to serial or parallel to parallel ports cable. To receive the files to a NTFS computer is possible by booting from floppy in plain DOS and acting using Virtual disks. It is tricky but if you have to save your life...

I can support, but maybe it is not a quick procedure to set-up.

Report •

Related Solutions

March 6, 2009 at 08:26:17
Are you sure that drive is a 1.44? Some of the older computers used a 720kb drive, which is the same physical size as the 1.44 (3 1/2). Try setting the newer machine to 720kb.

If the drive has a two cable connection, then it's probably an MFM or RLL interface and neither are compatible with IDE. There's also an older IDE interface (40 pin cable), which is incompatible with modern IDE controllers.

IVO has a good idea; if you don't have it, you can find pinouts for making a null modem cable here.

The down side to using a null modem cable is serial transmission can be painfully slow if you have a lot of files to transfer, and at that time, not all serial ports were standardized, so you'd need to verify the pinouts on both machines.

Good luck.

Report •

March 6, 2009 at 14:34:34
Could the problem be what is mentioned here under external storage

From what I could dig up it looks like:

1) Dos 3.3 1.44mb support - check
2) 80286 based PS/2's were said to come with 1.44mb drives as standard and the model 50 was 80286 based.
3) The floppy drives were are non standard size/mounting therefore unlikely to be a lower density replacement(unless scavenged from an older PS/2)

This is just from what I read though....

Have you tried formatting the disks in the newer machine(as standard 1.44) then copying the files onto the disks from the old machine?

The link cable stuff sound like the way to go if there are large volumes of data, even if the problem with the floppies does turn out to be so simple.

Report •

April 10, 2009 at 05:25:35
The PS 2 was an IDE interface (not that you would reconise the connector) and used a ST-506 controller.

I have recently installed DOS 3.3 on a pentium using a 1mb floppy, so a new machine will read the low density floppies formatted with this OS. The model 50 was 1.44Mb.

I use an early version of lap link (serial - serial/parallel) to transfer files and this works a treat.

Report •

Ask Question